charging system (bad alt) - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-07-2007, 04:26 PM
n00b
 
BALKAN's Avatar
 
Join Date: Dec 2006
Location: PA
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BALKAN is on a distinguished road
(Thread Starter)
Angry charging system (bad alt)

hello fellas.
Yes, im back again, now with a different problem. Batt. indicator lights up now, especialy at low rpms. I checked the battery which is slightly low 11.8 volts. Then i went to the front with the car at idle it reads the same, meaning the alt. is not charging. I had the wife rev up the car and it began charging. as the rpms came down it stops charging.
The question: Is the alt. junk, or is there something i can do to correct it.
I was really hoping it was the battery, since its so much cheaper than replacing the freakin alt.
BALKAN is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-08-2007, 08:56 PM
n00b
 
BALKAN's Avatar
 
Join Date: Dec 2006
Location: PA
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BALKAN is on a distinguished road
(Thread Starter)
Just got the car back. $450 and the alt. was replaced with a new lifetime alt. and i also had the mech. do rad. flush/fill. Not bad,,, I think.http://www.bimmerwerkz.com/forum/images/smilies/sad.gif
BALKAN is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Synthetic Oil and filter CiscoKid 3-Series (E36) 47 04-14-2014 07:00 PM
Charging System Light CiscoKid 3-Series (E36) 5 05-26-2006 01:37 PM
318i-Not charging Hypnogaja 3-Series (E21, E30) 15 10-27-2004 04:18 PM
The American Vs. The German billB 5-Series (E12,E28, E34, E39, E60) 83 10-14-2004 08:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome