Car Want Start So what am I missing?? - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-26-2012, 07:47 PM
n00b
 
Join Date: Jul 2008
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
duke1946 is on a distinguished road
(Thread Starter)
Car Want Start So what am I missing??

84 528e

Wife went to beach for Turkey Week. Went down on Sunday and the drove the car on Tuesday and then wanted to go to the gro on Wed to pick up something and all she got was a little bump two times but no start.

Put the jumper cables on it for her T day and just let it charge up for a little while and then with asst I started it up as my friend pulled the cables off ASAP. Then turned the car around so if need be any one could have access to jump it again.

Well Sunday she packed the car up and had a car ready for the jump and it fired right up????????

Today Monday. She went to start it and same as before. No start???

I had a good battery that a friend had just gave me and it was in top condition so I put it in and made sure all the connections were in good shape and the battery anti corrosion stuff was on and it fired right up. Charging oK once I kicked it a few dag times that is. Yep got to get the Alt rebuilt on it.

I took the old battery to my shop and thought it might be good to help crank something I need to start and move so I tested it with a battery tester and after 10 sec of holding a load on it the battery passed the test and did not fall below 12v? Hell the battery is as good as what I just put in the car

So what am I missing here? Could it be the old 84 battery connectors are failing even though the look ok and I have cleaned them in the pats to make sure that all is good? I did see some nice one that guys use when adding amps and stereo systems to theirs cars that AutoZone sells that I could use.
duke1946 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
94 740i V8 MISSING.. BMW_V8 1,6,7,8 - Series and Mini Cooper 4 03-07-2009 04:26 AM
sounds like its missing kevin.jacobs 5-Series (E12,E28, E34, E39, E60) 0 10-08-2008 03:04 PM
Missing Glass red330Iperfpkg Video Vault 8 03-28-2006 11:16 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome