Car Pulling To The Left - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-04-2005, 12:01 AM   #1 (permalink)
n00b
 
Join Date: Jul 2004
Location: San Francisco, CA
Car:
Posts: 36
Photos:
liquidtiger720 is an unknown quantity at this point
Send a message via AIM to liquidtiger720
My alignment results were as followed:
Left front:
Camber: -0.5 Caster: 7.1
Right front:
Camber: -0.9 Caster: 7.5

Left rear camber: -1.5
Right rear camber: -1.3

This is supposedly withing spec, but my car is still pulling to the left. I just replaced many suspension parts (upper/lower control arms, tie rod ends, center link, sachs sporting kit, pitman arms, sway bar links) except for the subframe bushings. What do you guys think would be causing the car to pull to the left?
__________________
liquidtiger720 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-04-2005, 05:19 AM   #2 (permalink)
da_administrator
 
da_bull's Avatar
 
Join Date: Jan 2005
Location: Mooooossouri
Car: Its slow, gotta M20 in it
Posts: 4,840
Photos:
da_bull has a reputation beyond reputeda_bull has a reputation beyond reputeda_bull has a reputation beyond reputeda_bull has a reputation beyond reputeda_bull has a reputation beyond reputeda_bull has a reputation beyond reputeda_bull has a reputation beyond reputeda_bull has a reputation beyond reputeda_bull has a reputation beyond reputeda_bull has a reputation beyond reputeda_bull has a reputation beyond repute
Send a message via MSN to da_bull
A couple of things come to mind: tire pressure and/or something in the brake realm: stuck (or rubbing) caliper/brake pads, wheel bearing. I am curious to what the alignment shop said after you told them it still pulls?
__________________


-There are 10 kinds of people. Those who understand binary, and those who do not.

-If we ever forget that we are One Nation Under God, then we will be a nation gone under...Ronald Reagan
da_bull is offline   Reply With Quote
Old 03-04-2005, 05:50 AM   #3 (permalink)
5th Gear Member
 
billB's Avatar
 
Join Date: Aug 2004
Location: New Jersey
Car:
Posts: 1,635
Photos:
billB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond repute
Send a message via Yahoo to billB
Could be the guy behind the machine himself. Did not know what he was doing? Can you go back to the same shop and double check the work?
A.Prior to any wheel aligment they do check the front end a piece by piece including tire pressure!
B. Wheel bearings are not shy...once bad they tend to scream at you
regards
billb
billB is offline   Reply With Quote
Old 03-04-2005, 10:35 PM   #4 (permalink)
n00b
 
Join Date: Jul 2004
Location: San Francisco, CA
Car:
Posts: 36
Photos:
liquidtiger720 is an unknown quantity at this point
Send a message via AIM to liquidtiger720
Quote:
Originally posted by billB@Mar 4 2005, 05:50 AM
Could be the guy behind the machine himself. Did not know what he was doing? Can you go back to the same shop and double check the work?
A.Prior to any wheel aligment they do check the front end a piece by piece including tire pressure!
B. Wheel bearings are not shy...once bad they tend to scream at you
regards
billb
[snapback]303680[/snapback]

They didnt check the air pressure, cause I just corrected that yesterday. it helped a little but not much.


They actually told me it was pulling left and didnt know why...just told me the car was withing spec. and stuff and the pull was probably due to the tires. Do you think not having weights in the car would cause the car to still pull left?
__________________
liquidtiger720 is offline   Reply With Quote
Old 03-05-2005, 05:04 PM   #5 (permalink)
5th Gear Member
 
billB's Avatar
 
Join Date: Aug 2004
Location: New Jersey
Car:
Posts: 1,635
Photos:
billB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond reputebillB has a reputation beyond repute
Send a message via Yahoo to billB
Is it possible to ask them to recheck their work; that is to say after the fact?
billB is offline   Reply With Quote
Old 03-06-2005, 11:37 AM   #6 (permalink)
n00b
 
Join Date: Jul 2004
Location: San Francisco, CA
Car:
Posts: 36
Photos:
liquidtiger720 is an unknown quantity at this point
Send a message via AIM to liquidtiger720
Quote:
Originally posted by billB@Mar 5 2005, 05:04 PM
Is it possible to ask them to recheck their work; that is to say after the fact?
[snapback]304489[/snapback]
I sure hope so. I didnt pay them 60 bucks to align my car to the left. haha. I am going to try rotating tires again this tuesday. I hope they won't give me trouble, they seemed like reasonable guys.
__________________
liquidtiger720 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems starting car when cold... VLAD_325is 3-Series (E36) 8 09-12-2005 08:08 PM
E46 Wire Guides (complete) EcianIce Audio and Electronics 2 09-26-2004 07:40 PM
Help wiring up amp install lude69 Audio and Electronics 13 08-15-2004 10:24 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:59 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.