BMW E34 Crankshaft position sensor - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-02-2008, 01:52 PM   #1 (permalink)
n00b
 
Join Date: Jun 2008
Location: United kingdom
Car: 1992 BMW E34 520i
Posts: 5
Photos:
Rolandos147 is on a distinguished road
BMW E34 Crankshaft position sensor

Hi I've got bmw e34 520i vanos 1992 year.. i just did alot of work on it by putting new engine my previous engine was 520i as well but it was non vanos, now i've got vanos which is slightly better but any way something went wrong with it doing my first test drive with new engine was ok it seemed to be much better than the old one i got 120 miles/h pretty easy after high revs and power tests i drive back home parked up and came back to my car after 20 min. went for another drive and weird things start happening i felt that i can nearly move got back on road floor it and in 2nd gear it could only do 5500 rpm and i could feel loads of misfiring, first thing i looked on temp but it was fine and there wasnt any mechanical faults on it engine sounded ok especially when running idle very smooth no misfiring any i ignore all that kept diving around later on that evening i parked up and my engine was running idle for 15 min and it sounded perfect! so i turned my ignition off than after another 15 minutes i try to start it and that was it, it never started up, actual engine was cranking but there was no sound of live in it like some one cut off petrol and spark! after many things i went thru i got it started some how but it was very badly misfiring i checked the timing it was perfect injection system and spark plugs were ok so i start checking all the sensors and i end up wit weird thing when i disconnect my crankshaft position sensor engine still runs with no change i replace the sensor but still no chang so its down to ECU now or maybe any one of you people have any other suggestions or maybe some one had the same problem??? And is it actually possible to reset my ecu???
Rolandos147 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-02-2008, 02:02 PM   #2 (permalink)
n00b
 
Join Date: Jun 2008
Location: United kingdom
Car: 1992 BMW E34 520i
Posts: 5
Photos:
Rolandos147 is on a distinguished road
here is some pic of engine i rebuild!!
Attached Thumbnails
BMW E34 Crankshaft position sensor-img_5639.jpg   BMW E34 Crankshaft position sensor-img_5640.jpg   BMW E34 Crankshaft position sensor-img_5652.jpg   BMW E34 Crankshaft position sensor-img_5737.jpg   BMW E34 Crankshaft position sensor-img_5742.jpg  

Rolandos147 is offline   Reply With Quote
Old 06-02-2008, 02:06 PM   #3 (permalink)
n00b
 
Join Date: Jun 2008
Location: United kingdom
Car: 1992 BMW E34 520i
Posts: 5
Photos:
Rolandos147 is on a distinguished road
And some more i had wiring loom so i could start my engine in garage and still see temp of it and rpm!!! pretty handsome!!!
Attached Thumbnails
BMW E34 Crankshaft position sensor-img_5745.jpg   BMW E34 Crankshaft position sensor-img_5750.jpg   BMW E34 Crankshaft position sensor-img_5754.jpg   BMW E34 Crankshaft position sensor-img_5755.jpg   BMW E34 Crankshaft position sensor-img_5770.jpg  

Rolandos147 is offline   Reply With Quote
Old 06-02-2008, 02:09 PM   #4 (permalink)
n00b
 
Join Date: Jun 2008
Location: United kingdom
Car: 1992 BMW E34 520i
Posts: 5
Photos:
Rolandos147 is on a distinguished road
Attached Thumbnails
BMW E34 Crankshaft position sensor-img_5771.jpg   BMW E34 Crankshaft position sensor-img_5779.jpg  
Rolandos147 is offline   Reply With Quote
Old 06-03-2008, 11:20 PM   #5 (permalink)
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Car: 88 super ETA, 95 525i
Posts: 1,494
Photos:
darkhorse737 is on a distinguished road
Cool

disconnect battery and leave it overnight. that will reset your ECU to it's original state.

as of this writing, i am nt sure if the ECU sans vanos is compatible with vanos... in all likelihood, what u are seeing is an ECU mismatch because the vanos mapping is distinctly different from non-vanos ;-)
darkhorse737 is offline   Reply With Quote
Old 06-04-2008, 02:10 PM   #6 (permalink)
n00b
 
Join Date: Jun 2008
Location: United kingdom
Car: 1992 BMW E34 520i
Posts: 5
Photos:
Rolandos147 is on a distinguished road
well i tried to leave it overnight with no battery, that didnt made any changes!! this ecu is original i took it off with all the engine and wiring loom cos i bought the whole car with this vanos engine just for spares!!! well i booked my self in BMW garage but i still have to wait until Tuesday thats like another 6 days but when i will get answer i will type it in here!!!
Rolandos147 is offline   Reply With Quote
Old 03-12-2012, 07:50 PM   #7 (permalink)
n00b
 
Join Date: Mar 2012
Car:
Posts: 3
Photos:
shaun535i is on a distinguished road
hello,
looks like i have the same issue.
just wont start.
changed crank
air flow
fuel pump
sparks...
what happened to your car-how did u solve it?
shaun535i is offline   Reply With Quote
Old 03-13-2012, 10:59 AM   #8 (permalink)
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Car: 1998 E36 328i
Posts: 2,210
Photos:
Lord Vader is on a distinguished road
OP, that's a really nice engine! I love the custom paint. Is that powder coated or just hi temp paint?
__________________

ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Camshaft Position Sensor nwiles 5-Series (E12,E28, E34, E39, E60) 1 08-07-2007 12:01 AM
FS: Camshaft Position Sensor - Intake GRIDLOCK OEM Parts 0 05-25-2007 06:29 PM
E34 pistons, connecting rods and Crankshaft Saggis 5-Series (E12,E28, E34, E39, E60) 0 03-23-2006 03:03 AM
Camshaft Position Sensor gigsy 5-Series (E12,E28, E34, E39, E60) 1 10-24-2005 12:08 AM
Picture of Throttle Position Sensor? tourist 3-Series (E36) 4 12-22-2003 02:06 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:39 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.