Battery and Blower Motor - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-12-2009, 12:16 PM   #1 (permalink)
n00b
 
Join Date: Feb 2009
Car:
Posts: 10
Photos:
nadeemkhan is on a distinguished road
Battery and Blower Motor

Battery keeps lossing charge so I have to jump start it... Hot/Cold air also doesn't blow at full. Alternator is fine and replaced the battery. I drove it all summer with no problem.

Read on the forum that the FSU could cause the problems but I couldn't find it then I read that the 91 models don't have them...

Any ideas on what and how to replace!!!
nadeemkhan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-2009, 11:27 AM   #2 (permalink)
n00b
 
Join Date: Feb 2009
Car:
Posts: 10
Photos:
nadeemkhan is on a distinguished road
I replaced the blower motor resister. Started the car and it ran for 5/10 minutes and got cut off. Now I can't jump start it. The motor wants to turn but won't turn. When I turn off the ignition after trying and failing to start, I hear a fan/motor running for a few seconds and I thinks it is drawing the power... Any suggestions!
nadeemkhan is offline   Reply With Quote
Old 02-26-2009, 11:39 AM   #3 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
There could be many issues to check for. From what I see, you may have anything from a bad ground to a fairly complex miss wiring problem. Does the car have climate control?
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
blower motor hughwhite New Members Check In 0 08-08-2008 09:39 AM
blower motor sycow 3-Series (E46, E90) 7 03-22-2006 06:27 PM
Blower Motor Eraj 3-Series (E36) 4 10-30-2004 03:03 AM
Blower Motor bimmerboy328i 3-Series (E36) 9 09-16-2004 05:00 PM
BLower motor Or Blower final stage unit tt540i 3-Series (E36) 0 06-24-2004 12:23 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:53 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.