ASC Light always on asc not working?? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-06-2008, 11:28 PM   #1 (permalink)
n00b
 
masesE39's Avatar
 
Join Date: Dec 2008
Location: Dayton Ohio
Car: 1998 540i black with black wheels
Posts: 17
Photos:
masesE39 is on a distinguished road
ASC Light always on asc not working??

i went out to my 98 540i the other day and when i started it the ASC light was no and i couldn't turn the ASC on the switch was not turning the ASC on and off
does anyone have any info on this i live in ohio and its about time that we get a lot of snow and i would love to have my ASC working help please!!!
masesE39 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-06-2008, 11:35 PM   #2 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
It may be as simple as a brake fluid service (change), like with ABS brakes.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 12-06-2008, 11:50 PM   #3 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
usually it is the wheel speed sensors have the codes read then i can help better!
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 12-07-2008, 12:00 PM   #4 (permalink)
n00b
 
masesE39's Avatar
 
Join Date: Dec 2008
Location: Dayton Ohio
Car: 1998 540i black with black wheels
Posts: 17
Photos:
masesE39 is on a distinguished road
but there is no abs light or brake light on?? so i didn't think that it could be a wheel speed sensor???
masesE39 is offline   Reply With Quote
Old 12-07-2008, 04:21 PM   #5 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
hmmm... should still have some kind of error code.... unless the button is stuck and always turning it off??? could be a bad ASC controller...
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 12-07-2008, 06:09 PM   #6 (permalink)
n00b
 
masesE39's Avatar
 
Join Date: Dec 2008
Location: Dayton Ohio
Car: 1998 540i black with black wheels
Posts: 17
Photos:
masesE39 is on a distinguished road
do you know how to take out the asc button so i can test the switch for continuity when pessed in and out??? i have and xm radio and i had it sitting in front of the button i wonder if the xm unit was pressing against the button all the time frying the switch??
masesE39 is offline   Reply With Quote
Old 12-08-2008, 10:39 PM   #7 (permalink)
n00b
 
masesE39's Avatar
 
Join Date: Dec 2008
Location: Dayton Ohio
Car: 1998 540i black with black wheels
Posts: 17
Photos:
masesE39 is on a distinguished road
n00b

Join Date: Dec 2008
Car:
Posts: 3
Photos: 0
masesE39 is on a distinguished road

do you know how to take out the asc button so i can test the switch for continuity when pessed in and out??? i have and xm radio and i had it sitting in front of the button i wonder if the xm unit was pressing against the button all the time frying the switch??
masesE39 is offline   Reply With Quote
Old 12-09-2008, 12:38 AM   #8 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
^???? ummmmmm ok then.....

The button just pops right out just Gently pry it out....
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 12-09-2008, 08:35 AM   #9 (permalink)
n00b
 
masesE39's Avatar
 
Join Date: Dec 2008
Location: Dayton Ohio
Car: 1998 540i black with black wheels
Posts: 17
Photos:
masesE39 is on a distinguished road
o ok thought you might have to take out middle console to get to it thanks!! i will give it a shot and see what happens i hope its the switch and not the asc control
masesE39 is offline   Reply With Quote
Old 12-10-2008, 11:00 PM   #10 (permalink)
n00b
 
masesE39's Avatar
 
Join Date: Dec 2008
Location: Dayton Ohio
Car: 1998 540i black with black wheels
Posts: 17
Photos:
masesE39 is on a distinguished road
found problem with asc light staying on!!

As i was looking at the prethrottle cable and motor the cable attaches to it. I found the problem, the cable was in place but the cable was broke where you couldnt see it. I didnt see it until i turn the throttle plate by hand and the cable didnt return to fixed position. I then pulled on the cable when it slid right out of the casing witch goes to the motor. so bingo!! new cable $ 12.80 loved it...lol also the code was 39 38 for the prethrottle not opening and closing.
If anyone has same prob with asc light on ONLY!!! check for this. you will also notice lost in power even with asc turned off and worse gas mileage. Thanks Every one for the help!!
masesE39 is offline   Reply With Quote
Old 12-10-2008, 11:11 PM   #11 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Glad to see you found your answer!
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 12-11-2008, 08:10 AM   #12 (permalink)
n00b
 
mrmojo37's Avatar
 
Join Date: Nov 2008
Location: Cottage Grove, Oregon U.S.A.
Car: 1997 528i
Posts: 18
Photos:
mrmojo37 is on a distinguished road
My ASC light stays on. My gas milage is poor. I have a 1997 528i. What exactly is a pre-throttle cable and what does it do?
mrmojo37 is offline   Reply With Quote
Old 12-11-2008, 09:19 AM   #13 (permalink)
n00b
 
masesE39's Avatar
 
Join Date: Dec 2008
Location: Dayton Ohio
Car: 1998 540i black with black wheels
Posts: 17
Photos:
masesE39 is on a distinguished road
well the pre-throttle is a throttle body that is connected to your intake tube. you have two in our case because of the traction control. one witch is after the airbox and one that blots to the intake manifold.The first one is your pre-throttle. It controls rpm and air intake to the eingne to help the traction control work. so if the cable is broke and the throttle plate is stuck in one position the asc system will see this and shut down the hole system and turning your asc light on all the time. The cable runs from the first throttle body to the right side of the engine bay if you looking at the engine!! if you turn the throttle plate by using the throttle linkage and the cable does return to being straight and it stays looped up by linkage try pulling cable out of sleeve if its broke on either side you will notice when you pull on it or when you open the throttle plate. Hope this gives you some idea how it works and where it is. let me know if you have anymore questions and good luck
masesE39 is offline   Reply With Quote
Old 12-19-2008, 08:01 PM   #14 (permalink)
n00b
 
Join Date: Aug 2008
Car:
Posts: 20
Photos:
mybeamer is on a distinguished road
hey i have the same problem. i pulled the cable and cant find the other end. where is the motor that the cable hooks up 2. i looked under the booster and the abs unit and the master cylinder and cant find it. even my boss cant find it. i work in a shop and im going to look again tomorrow. please help. by the way my car is a 94 530 i. thank you
mybeamer is offline   Reply With Quote
Old 12-21-2008, 10:42 PM   #15 (permalink)
n00b
 
masesE39's Avatar
 
Join Date: Dec 2008
Location: Dayton Ohio
Car: 1998 540i black with black wheels
Posts: 17
Photos:
masesE39 is on a distinguished road
well i am not sure since you have a 94 and mine is a 98 540 but my motor is on the right side almost on the wheel well there is the cruise control motor and bolted to the front of that motor is the motor for the pre throttle body..... I hope this helps let me know??
masesE39 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ASC Light is on BolMenWheelz 5-Series (E12,E28, E34, E39, E60) 1 01-22-2008 03:54 PM
asc light comes on while driving cabrit 3-Series (E36) 9 10-03-2006 01:31 AM
Abs,asc Lights On + Speedo Not Working ghazanfer 5-Series (E12,E28, E34, E39, E60) 2 06-06-2005 11:55 AM
ASC light is on Franks528i 5-Series (E12,E28, E34, E39, E60) 29 05-28-2005 10:01 AM
ASC and Airbag Light on M3WANNAB 3-Series (E36) 1 08-11-2004 06:41 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:14 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.