Alien in my dashboard? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-19-2009, 04:02 AM   #1 (permalink)
Neutral Member
 
Join Date: Jan 2009
Location: Taif. Saudi Arabia
Car: 1997 E39 540i
Posts: 82
Photos:
harryinsaudi is on a distinguished road
Alien in my dashboard?



My 97 540 IA has started making funny little beep/pop noises from the region of the instrument cluster. Sounds like a voltage being applied to a speaker momentarily then disconnecting. It's not from the stereo, I've tried switching the R/T tel buttons on the steering wheel. Does it when engine on or off...... varies in beat not loud but just loud enough to be annoying....... The car does not give an audi alarm when exceeding the limit set. Not sure if it is supposed to or not. Maybe it was disconnected by a previous owner and something touching the speaker? Any clues out there.
harryinsaudi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-19-2009, 05:26 AM   #2 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
It should give an audible alarm when you have reached the speed limit you have set, so maybe you are correct and the previous owner disconnected it, I think you will have to do some investigation in the wiring department.

Start by removing the cluster and see if all is ok there, then move on...
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
(!) Dashboard Light ismbal 3-Series (E36) 3 06-26-2008 03:45 PM
Dashboard PhatCat 3-Series (E21, E30) 0 11-21-2006 03:38 PM
Dashboard Help eat_mor_chikin 3-Series (E21, E30) 1 10-23-2004 08:32 PM
X5 Dashboard jstoiber 1,6,7,8 - Series and Mini Cooper 2 04-21-2004 02:42 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:15 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.