! - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-14-2011, 12:52 PM
n00b
 
Join Date: Aug 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
brandoncrrll is on a distinguished road
(Thread Starter)
!

HI guys i just bought this 98 528i automatic. The previous owner said the water pump and thermostat were just replaced and said it had some overheating problems, but just needed to be topped off with fluid and should be fine. I topped off the exp. tank and 5 minutes into my drive the temp started to sore.
When i got it towed back home checked it out.
-The oil doesnt appear to be milky
-Cant really see and contaminents in coolant.
-The car will not overheat at idle, only when getting up to speed
-The top hose is very hot, the bottom is cool
- When i leave the exp tank cap and bleeder off, the bleeder will let alot of gas out and i cant maintain a level in the exp. tank. I will add some fluid then it will overflow, and then the level will drop way down...
I fear this is a blown head gasket. Maybe the shop screwed up on the thermostat job? i sure hope so. I think the prev owner may be hiding something from me. ON the paper it said he went in for a coolant leak and then they replaced the pump and thermostat, and then maybe the overheating problem arised?... thanks for any suggestions theyre much appreciated!
brandoncrrll is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-14-2011, 12:55 PM
n00b
 
Join Date: Aug 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
brandoncrrll is on a distinguished road
(Thread Starter)
Additionally, there is no visiable white smoke coming out the exhaust, atleast when its running at idle in my garage.
The check engine light is on ofcouse, i tried doing the diagnosis where you press the accelerater pedal 5 times but the light just stayed on and didnt do anything. Does that not work for this year?
brandoncrrll is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome