98 540i electrical problems - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-22-2009, 01:16 PM
n00b
 
Join Date: Apr 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
katscorp is on a distinguished road
(Thread Starter)
Unhappy 98 540i electrical problems

Hi. got a dandy problem, i think.....
Sterio will not work along with all controlls on the steering wheel, signals and all that work but no horn, illuminasion of buttons, volume and cruz control do not work.
after a few days, everything was working again, then it all quit and same probs.
the car starts and drive fine.
I have checked all the fuses and they are good.......any suggestions?

Thanks
katscorp is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-22-2009, 01:31 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,702
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
There's evidently a loose connection in the column. Does the car have an airbag, and has that been serviced?

BMW

Sig by zeaq
witeshark is offline  
#3 (permalink) Old 04-22-2009, 02:13 PM
n00b
 
Join Date: Apr 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
katscorp is on a distinguished road
(Thread Starter)
Yes it does have airbags, It hasen't been serviced scince I have owned it. ( 9 months)
I understand the steering wheel not functioning properly because of a loose wire but would that cause the radio itself not to work?

Thanks
katscorp is offline  
#4 (permalink) Old 04-22-2009, 03:17 PM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
I would be looking more at the ignition switch, which is not the barrel but is an electrical switch at the end of the barrel........common fault.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#5 (permalink) Old 04-23-2009, 12:25 AM
n00b
 
Join Date: Apr 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
katscorp is on a distinguished road
(Thread Starter)
Sometimes it works nd other times it doesn't. No real pattern just weird. I'll get it checked out and let you know.
Thanks
katscorp is offline  
#6 (permalink) Old 04-23-2009, 12:58 AM
5th Gear Member
 
CosmosBlack's Avatar
 
Join Date: Jul 2003
Location: Florida
Posts: 1,289
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute CosmosBlack has a reputation beyond repute
marti is right, it could well be the ignition switch, a common problem.
I don't know if it's the same in a '98, but you should also look at the fusible link, by the battery. They get loose or corrode over time, causing similar symptoms.



2012 Porsche 911 GTS
2008 Ford F150 Foose Edition
2010 VW Touareg

----------------------------------
Gone...2002 Porsche 911 C4S
Gone...2000 BMW 540i
Gone...1995 BMW 540i
CosmosBlack is offline  
#7 (permalink) Old 05-26-2009, 10:34 AM
n00b
 
Join Date: Apr 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
katscorp is on a distinguished road
(Thread Starter)
Thanks everyone! it was the ignition switch.
katscorp is offline  
#8 (permalink) Old 05-26-2009, 10:54 AM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,702
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
Glad to see you got it sorted!

BMW

Sig by zeaq
witeshark is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problems chrism_88 Z3 / Z4 /ZM 2 07-20-2008 11:03 AM
Electrical problems jrsbmw 3-Series (E21, E30) 5 02-08-2007 10:12 PM
Electrical Problems Duge 3-Series (E36) 12 04-30-2005 06:41 PM
Electrical Problems Edrandall79 3-Series (E21, E30) 4 05-31-2004 12:41 PM
Electrical problems Hamann 325i 3-Series (E36) 0 10-06-2003 10:42 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome