92 e34 535i oil leak - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-29-2009, 09:42 AM
n00b
 
CAMO_92_535i's Avatar
 
Join Date: Sep 2009
Location: Manchester, New Hampshire
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CAMO_92_535i is on a distinguished road
Send a message via AIM to CAMO_92_535i Send a message via MSN to CAMO_92_535i Send a message via Yahoo to CAMO_92_535i
(Thread Starter)
92 e34 535i oil leak

Whats up guys it's been a bit since I have posted. Well I had a low oil pressure come up on my display. I looked underneath the hood and realized I had a bunch of oil that should of been in my engine. I got a leak test dye kit and come to the conclusion that it's coming from the top of my oil filter housing unit. So I got a new gasket for the fix. Anyone every have this problem. Thanks for you time.



Drive it like you Stole it!

"Who's 92 BMW 535i is that.....Mine"
CAMO_92_535i is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-29-2009, 09:54 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
Yep, Had it on my 7, still leaked after I put a new 'O'ring in, so ordered a new top from BM did the job again....all fixed,its now been 8 months and all is well.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#3 (permalink) Old 10-29-2009, 09:59 AM
n00b
 
CAMO_92_535i's Avatar
 
Join Date: Sep 2009
Location: Manchester, New Hampshire
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CAMO_92_535i is on a distinguished road
Send a message via AIM to CAMO_92_535i Send a message via MSN to CAMO_92_535i Send a message via Yahoo to CAMO_92_535i
(Thread Starter)
Thanks so much. So I guess i'll be getting a new top. The o-ring I already have. If you don't mind me asking were did u got to get it? But thanks yet again, you saved another bimmers life!



Drive it like you Stole it!

"Who's 92 BMW 535i is that.....Mine"
CAMO_92_535i is offline  
#4 (permalink) Old 10-29-2009, 04:44 PM
n00b
 
CAMO_92_535i's Avatar
 
Join Date: Sep 2009
Location: Manchester, New Hampshire
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CAMO_92_535i is on a distinguished road
Send a message via AIM to CAMO_92_535i Send a message via MSN to CAMO_92_535i Send a message via Yahoo to CAMO_92_535i
(Thread Starter)
So i got a new O-ring and Assembly of my Oil Filter Housing along with a oil change. So now everythings in and the leak seems to have stopped. Now my "Oil Light" and my "ENGINE OIL PRESSURE" is still being displayed. Now the only time it is displayed is once my car is fully heated up in idle, and when i down shift once my engine is fully warmed up. When im driving they dont appear and the car is running fine but once i push in the clutch to down shift it lights up. I dont hear any ticking in the engine when its in idle or when im down shifting. So i dont know if its faulty wiring or worse case my engine oil pump. thanks for you time.



Drive it like you Stole it!

"Who's 92 BMW 535i is that.....Mine"

Last edited by CAMO_92_535i; 10-29-2009 at 05:09 PM.
CAMO_92_535i is offline  
#5 (permalink) Old 10-29-2009, 07:35 PM
1st Gear Member
 
Join Date: Feb 2009
Location: Las Vegas
Posts: 273
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
coolvegase34 is an unknown quantity at this point
Maybe the computer needs to be reset.
coolvegase34 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
92 535i e34 CAMO_92_535i 5-Series (E12,E28, E34, E39, E60) 2 10-01-2009 11:28 AM
What MPG with a E34 535i? justin93 5-Series (E12,E28, E34, E39, E60) 5 06-28-2009 05:59 PM
King 535i (E34) Gontse New Members Check In 2 10-15-2008 09:55 AM
Too Much Oil, Wrong Oil, Gas Leak? yammahamma 3-Series (E21, E30) 4 07-26-2005 07:20 PM
Need some help with an E34 535i (1990) SeanH 5-Series (E12,E28, E34, E39, E60) 4 09-03-2003 03:37 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome