83 528e, sometimes it starts and sometimes it doesn't. - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-02-2012, 04:27 PM   #1 (permalink)
n00b
 
Join Date: Sep 2011
Car:
Posts: 4
Photos:
Clemson88 is on a distinguished road
83 528e, sometimes it starts and sometimes it doesn't.

I'v changed the cap and rotor, plugs, wires and coil. The coil shows power on a cheap test light but the plugs' spark is weak. The wiring diagram shows at least one of the coil wires going to the ECU or module. I suppose that is the next part to change. Can someone tell me where the ECU is located on this car?
Clemson88 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2012, 08:00 AM   #2 (permalink)
Captain... Savvy ?
 
Jack Dabsy's Avatar
 
Join Date: Apr 2011
Location: Barnsley UK
Car: BMW E38 728i 1996 Met Black
Posts: 2,194
Photos:
Jack Dabsy will become famous soon enough
Garage
Hi Clemson...
Your ECU (ECM) is located above the glove-box
__________________

Eso es todo!
Please press the "REP" button if you are happy with your response/answer...

Please JOIN, or just have a look... Its Totally FREE...
BMW Part Market

BMW Online Manuals (TIS)

New Member ?
Jack Dabsy is offline   Reply With Quote
Old 03-03-2012, 09:29 AM   #3 (permalink)
n00b
 
Join Date: Sep 2011
Car:
Posts: 4
Photos:
Clemson88 is on a distinguished road
Thank you Dabsy.
Clemson88 is offline   Reply With Quote
Old 03-05-2012, 01:47 PM   #4 (permalink)
n00b
 
Join Date: Dec 2011
Car: 1989 BMW 535i
Posts: 49
Photos:
rivroshaun951 is on a distinguished road
Before you replace that ECU what else have you done to solve this no start issue? Have you checked the battery? Have your checked the starter? Relay? Wires? Fuel? etc....etc...
rivroshaun951 is offline   Reply With Quote
Old 03-06-2012, 02:49 PM   #5 (permalink)
Captain... Savvy ?
 
Jack Dabsy's Avatar
 
Join Date: Apr 2011
Location: Barnsley UK
Car: BMW E38 728i 1996 Met Black
Posts: 2,194
Photos:
Jack Dabsy will become famous soon enough
Garage
+1

I had a similar issue the other Month... New Battery solved this !
However, have the Starter tested anyway just to eliminate it...
__________________

Eso es todo!
Please press the "REP" button if you are happy with your response/answer...

Please JOIN, or just have a look... Its Totally FREE...
BMW Part Market

BMW Online Manuals (TIS)

New Member ?

Last edited by Jack Dabsy; 03-06-2012 at 02:51 PM.
Jack Dabsy is offline   Reply With Quote
Old 03-25-2012, 06:05 PM   #6 (permalink)
n00b
 
Join Date: Sep 2011
Car:
Posts: 4
Photos:
Clemson88 is on a distinguished road
Thanks for all the response folks.

Quote:
Originally Posted by Dabsy View Post
+1

I had a similar issue the other Month... New Battery solved this !
However, have the Starter tested anyway just to eliminate it...
The engine always turns over fine. The fuel supply is good. The problem is the spark. Sometimes the spark is weak, so weak that it just won't run. I've changed the everything I know in the ignition except the switch and the ECU.

This is one of the half-breeds that was manufactured during 02/83. It has the distributor cap that looks like a squid fleeing from danger.

I have searched above the glove box and nothing that faintly resembles the listed ECU units resides there. There is a small green box resting above a large metal (8"X8") box.

The car use to shut down then after a short period perhaps 10 to 15 minutes it would fire up again and do fine. This reoccurred with more frequency until the last few months. Now It just doesn't get any fire at all coming from the distributor. I'm not sure I understand this ignition system but from what I read the low voltage signal sent to the ECU incites a high voltage output from the coil which is then sent through the distributor to the plugs.

If this is the case wouldn't that narrow the problem down to the ECU? Anybody?
Clemson88 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No electrics but car starts fester001 5-Series (E12,E28, E34, E39, E60) 2 05-06-2009 11:22 PM
Only When It Starts einstine98 3-Series (E36) 2 12-13-2004 01:58 AM
85 BMW 528E 528E Exhaust dragonforlife 5-Series (E12,E28, E34, E39, E60) 4 06-14-2004 02:56 PM
Hard starts dubumb 5-Series (E12,E28, E34, E39, E60) 16 01-23-2004 05:50 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:22 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.