2003 E39 - Battery/Electrical Problem - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-29-2009, 04:59 PM   #1 (permalink)
n00b
 
Join Date: Nov 2009
Car:
Posts: 2
Photos:
goldschlager1 is on a distinguished road
2003 E39 - Battery/Electrical Problem

Hello - similar post to - http://www.bimmerwerkz.com/forum/5-s...nal-59294.html

Drove car to store, came out after ten minutes, turned off alarm and all electrical died - no start, no dash lights, no radio, no powerlocks, etc. After research online I found above post, opened trunk lid (using manual override), and jiggled red cable from battery terminal.... power came back and car started fine.

My question is - what is the diagnosis of the problem and what actions should I take to prevent from occurring again?

Thanks in advance for your advice.
goldschlager1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-29-2009, 05:49 PM   #2 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Is there any sign of corrosion or dirt on the battery terminal?
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 11-30-2009, 03:44 AM   #3 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
Tighten you battery terminals up....
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 12-01-2009, 10:28 AM   #4 (permalink)
n00b
 
Join Date: Nov 2009
Car:
Posts: 2
Photos:
goldschlager1 is on a distinguished road
No corrosion - happened again this AM - had to have a neighbor jiggle the red battery cable while I started the car (otherwise power would cut back out as soon as I tried to start the car after restoring the power by "jiggling" myself). Terminal seemed tight but will tighten later today. From other posts elsewhere tightening didn't solve the problem but I'll keep my fingers crossed
goldschlager1 is offline   Reply With Quote
Old 12-01-2009, 10:43 AM   #5 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
It could possibly be the battery internals have corroded away under the + post thats why a jiggle does it......so basically you have a dead cell or an internal short, so new battery required.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New member 525i se 2003 electrical problem talatm New Members Check In 3 12-02-2009 06:43 AM
2000 530d e39 electrical problem RSK2831 5-Series (E12,E28, E34, E39, E60) 7 03-25-2009 02:56 AM
E39 Electrical problem Phillip Visser 5-Series (E12,E28, E34, E39, E60) 7 02-06-2009 03:38 AM
E39 Electrical Problem sema4 5-Series (E12,E28, E34, E39, E60) 0 11-10-2008 04:04 AM
Electrical Problem - Battery Being Drained snpower 3-Series (E21, E30) 2 04-05-2008 09:04 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:45 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.