2002 bmw e39 525i p0171 p0174 sytem too lean bank1 bank 2 help? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-10-2010, 11:16 AM   #1 (permalink)
n00b
 
Join Date: Mar 2009
Car:
Posts: 3
Photos:
my bimmer 2002 is on a distinguished road
Angry 2002 bmw e39 525i p0171 p0174 sytem too lean bank1 bank 2 help?

Hi aim going pretty much crazy with my 2002 BMW e39 525i with 78k miles i have been getting these codes p0171 , p0174 system too lean bank 1 bank 2.
I have done pretty much everything and spent hundreds on dealers and repair shops any help would be highly appreciated i have done the fallowing repairs >

1.replaced all 4 oxygen sensors Bosch brand.
2.replaced air cleaner box.
3.replaced both air boots.
4.replaced ccv valve.
5.clean maf sensor.
6.used seafoam cleaner
7.car seems to run fine engine idles good not rough i always us highest gas so any ideas on what to do would be highly appriciated thanks

p.s

I already changed both air intake elbows and i don't hear any engine noise and all the air hoses seem to be fine i think because i sprayed the air intake and most hoses with carb cleaner and didn't noticed any difference on the idle any help and suggestions would be thank full
my bimmer 2002 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-21-2010, 02:18 AM   #2 (permalink)
n00b
 
Join Date: Feb 2010
Car:
Posts: 15
Photos:
chraw1 is on a distinguished road
I've found a intake leak on my doing the same thing
chraw1 is offline   Reply With Quote
Old 03-21-2010, 04:59 PM   #3 (permalink)
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Car: 88 super ETA, 95 525i
Posts: 1,494
Photos:
darkhorse737 is on a distinguished road
Lightbulb

the #1 thing you should have done before resorting to all that you described:
should have been to:

1) check fuel pump to see it gives out correct fuel pressure;
2) if pressure before fuel filter is within specs, check fuel filter(or change)
3) clear the codes and re-test

**in the unusual event that it still comes on, then the fuel pressure regulator should be next in line to check.

LOGIC: when you have system lean, both banks, that indicates "not enough gas". Therefore, check gas supply first.

TIP: when you have codes showing both symptoms for both banks 1 & 2; you should move further upstream and see which engine components are "central"/shared by both banks 1 & 2

;-)

Last edited by darkhorse737; 03-21-2010 at 05:03 PM.
darkhorse737 is offline   Reply With Quote
Old 03-22-2010, 12:03 AM   #4 (permalink)
n00b
 
Join Date: Feb 2010
Car:
Posts: 15
Photos:
chraw1 is on a distinguished road
As I said before not a good mac

Rely on mac in the trade thats what i've been told feel like quite a retard
feul filter needs changeing but have not found one for this car yet it has 4 connection and the one that show in the book are only two thanks again for all your help
chraw1 is offline   Reply With Quote
Old 03-22-2010, 06:55 AM   #5 (permalink)
n00b
 
virusoid's Avatar
 
Join Date: Jun 2009
Location: Chandler, AZ
Car: 1998 740iL
Posts: 5
Photos:
virusoid is on a distinguished road
My 98 540i was throwing the same codes. It was my throttle body gasket. About $10. Spray some throttle body cleaner around the gasket area while the car is idling. If it starts to speed up then you know that's the problem. Mine wanted to die instantly. The icv (ignition control valve, only on 97 & 98's) was completely gummed up. Changed gaskets and cleaned out the icv w/ WD40 and it runs perfect now. I'm going to do this to my 98 740iL next week as preventative maintenance (206K miles).
Good luck, hope this helps!
virusoid is offline   Reply With Quote
Old 03-22-2010, 12:18 PM   #6 (permalink)
n00b
 
Join Date: Feb 2010
Car:
Posts: 15
Photos:
chraw1 is on a distinguished road
thanx will try this
chraw1 is offline   Reply With Quote
Old 03-27-2010, 02:38 AM   #7 (permalink)
n00b
 
Join Date: Feb 2010
Car:
Posts: 15
Photos:
chraw1 is on a distinguished road
well thank you all for your help found what was wrong it was blocked vacum pipes and connector that was causeing all the trouble
chraw1 is offline   Reply With Quote
Old 03-27-2010, 04:05 AM   #8 (permalink)
42, The meaning of life
 
brettski's Avatar
 
Join Date: Jul 2009
Location: Melbourne, Australia
Car: 2000 740iL Individual
Posts: 2,405
Photos:
brettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nice
Well done. The problem is gone now, but what was blocking the line?
brettski is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0171&P0174 codes pop up. anyone have a clue?? coolcooltracy 3-Series (E46, E90) 4 11-02-2009 05:19 PM
p0171 and p0174 code help,,01 740i bosanci28 1,6,7,8 - Series and Mini Cooper 2 05-13-2009 08:31 AM
Intake boots, and lean P0171 P0174 codes longrob 5-Series (E12,E28, E34, E39, E60) 2 03-23-2009 03:50 PM
2002 525i E39 amh 5-Series (E12,E28, E34, E39, E60) 0 06-14-2008 08:19 AM
2002 BMW 525i Burning Oil Harlen'W 5-Series (E12,E28, E34, E39, E60) 9 11-17-2006 10:25 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:39 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.