1997 E39 rough cold starts and loud air pump - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-16-2008, 01:44 PM
n00b
 
Join Date: Jul 2004
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sugarmel is an unknown quantity at this point
(Thread Starter)
Angry 1997 E39 rough cold starts and loud air pump

My car runs rough (like it is missing) on cold starts, and the secondary air pump sounds loud. After about two cold starts, the check engine light comes on. The fault code is "F0" which is "Misfire detected on cyclinder 3". I have swapped out coils, and plugs with other cylinders, but I keep getting the problem with cylinder 3. After a few minutes of the cold start, the idling smooths out, and the pump gets quieter before the pump eventually shuts off. I have changed the valve for the air pump also. Any ideas as to what I shouls check next? Thanks.
Sugarmel is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-16-2008, 04:25 PM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
have u changed your air pump filter lately? :-?
darkhorse737 is offline  
#3 (permalink) Old 07-16-2008, 10:23 PM
n00b
 
Join Date: Jul 2004
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sugarmel is an unknown quantity at this point
(Thread Starter)
No, I haven't. Will try that and get back my findings.
Sugarmel is offline  
#4 (permalink) Old 07-16-2008, 10:24 PM
Neutral Member
 
Join Date: Mar 2008
Location: Owensboro, Ky.
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
prmoorman1 is on a distinguished road
Send a message via Skype™ to prmoorman1
Darkhorse, where is the air pump filter located, and what does it look like?
My 97 528i seem to make a similar noise, like an exhaust leak upon start up.
prmoorman1 is offline  
#5 (permalink) Old 07-16-2008, 10:56 PM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Smile

Right hand side, front of wheel well, sir... ;-)
darkhorse737 is offline  
#6 (permalink) Old 07-17-2008, 08:18 AM
Neutral Member
 
Join Date: Mar 2008
Location: Owensboro, Ky.
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
prmoorman1 is on a distinguished road
Send a message via Skype™ to prmoorman1
Can ya actually just replace the filter,or do one have to replace the pump.
Again,what is the sign that sez,to change the filter,or replace the pump?
Thanx Darkhorse!!! It is good to know these things,I have only been a
beamer owner since Dec.
prmoorman1 is offline  
#7 (permalink) Old 07-17-2008, 08:42 AM
LOS
4th Gear Member
 
LOS's Avatar
 
Join Date: Apr 2004
Location: L.A Calif.
Posts: 863
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
LOS is an unknown quantity at this point
Sugarmel, it could also be your MAF sensor...

LOS
LOS is offline  
#8 (permalink) Old 07-17-2008, 09:03 AM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Lightbulb

Quote:
Originally Posted by prmoorman1 View Post
Can ya actually just replace the filter,or do one have to replace the pump.
Again,what is the sign that sez,to change the filter,or replace the pump?
Thanx Darkhorse!!! It is good to know these things,I have only been a
beamer owner since Dec.
look carefully at the top of the air pump. You might see a cover that you can pry or twist to expose the filter.

If in doubt, call your local dealer and request for them to fax you an exploded view of the air pump assembly. and it will show ;-) they do not charge for that service.
darkhorse737 is offline  
#9 (permalink) Old 07-17-2008, 09:06 AM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
darkhorse737 is on a distinguished road
Exclamation

SugarMel, i forgot to ask... did u ever get a compression reading on your #3 cylinder? If yes, what was the pressure please?
darkhorse737 is offline  
#10 (permalink) Old 07-19-2008, 12:50 PM
n00b
 
Join Date: Jul 2004
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sugarmel is an unknown quantity at this point
(Thread Starter)
I have not had a compression reading. I will look into getting one done. Also, I do not get any error code for the MAF meter.
Sugarmel is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
secondary air pump has become very loud... 98three28i 3-Series (E36) 1 05-01-2006 10:02 PM
1997 328i Rough Idle on Cold Start Larry Horne 3-Series (E36) 14 01-25-2006 12:09 AM
Air Pump Loud At Startup tacroteau 5-Series (E12,E28, E34, E39, E60) 1 04-21-2005 01:32 PM
1997 740 Dinan 1 Running Rough When Cold francene1 1,6,7,8 - Series and Mini Cooper 0 03-30-2005 06:13 PM
very hard cold starts+ rough idle ????? jshores7 3-Series (E36) 5 03-02-2004 08:57 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome