1994 E34 530i Won't Start! Please Help! - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-22-2008, 04:42 PM
n00b
 
Join Date: Aug 2008
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
E34HartgeH5 is on a distinguished road
(Thread Starter)
1994 E34 530i Won't Start! Please Help!

Hey everyone.

Well, today my recently acquired 1994 530i 5 speed wouldn't start. I noticed earlier on in the week when the car had been running for awhile and got hot it had a hard time to start (like when i stopped for gas for a few minutes and went to leave i had to crank it several times AND pump the gas pedal). The car turns over but it doesn't sound like it wants to catch. Since this car is new to me and i'm not familiar with it yet...am i supposed to hear the fuel pump when i put the key in the forward position in the ignition? When i tried starting it a few times i wasn't smelling gas at all either.

The car has 90k miles on it and it seems to have been well cared for. It idles (idled) perfectly before today and it has (had) LOTS of power to it still (when it runs).

If anyone can guide me in the right direction that would be great...right now i'm so depressed and my mechanic is only back at the garage next Wednesday.

Thanks.
E34HartgeH5 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-23-2008, 10:05 AM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
darkhorse737 is on a distinguished road
shoot some brake/carb cleaner, starter fluid into the throttle body.... START.

Runs momentarily?..
Yes= fuel pump/fuel filter prob; fuel pump fuse; or fuel pump relay
NO= electrical problem.

Good luck to you.
darkhorse737 is offline  
#3 (permalink) Old 08-25-2008, 11:31 AM
n00b
 
Join Date: Aug 2008
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
E34HartgeH5 is on a distinguished road
(Thread Starter)
Well, it ended up being a defective fuel pump relay...THANK god The beast is back on the road again!
E34HartgeH5 is offline  
#4 (permalink) Old 08-25-2008, 01:48 PM
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Posts: 1,494
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
darkhorse737 is on a distinguished road
Thumbs up

YOU FOUND THE PROB... kudos to you!!! :-D
darkhorse737 is offline  
#5 (permalink) Old 08-25-2008, 07:32 PM
n00b
 
Join Date: Aug 2008
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
E34HartgeH5 is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by darkhorse737 View Post
YOU FOUND THE PROB... kudos to you!!! :-D
Yup, and i'm super happy! I love this car SOOOOOOOOOOO much. Not only does it look good...it is quick. My friends 95 Mustang GT can't keep up with my H5 at all
E34HartgeH5 is offline  
#6 (permalink) Old 09-03-2008, 12:53 AM
n00b
 
Join Date: Sep 2008
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bpearson is on a distinguished road
Location of the fuel pump relay on a 94 530i. I am having the same issue. thanks in advance.
bpearson is offline  
#7 (permalink) Old 09-03-2008, 08:57 PM
n00b
 
Join Date: Aug 2008
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
E34HartgeH5 is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by bpearson View Post
Location of the fuel pump relay on a 94 530i. I am having the same issue. thanks in advance.
It's located in the big black plastic box near the firewall on the passenger side. Remove the 4 screws to remove the cover off and you will see the relays.

My car has had NO problems at all since i changed the relay
E34HartgeH5 is offline  
#8 (permalink) Old 09-05-2008, 11:31 AM
n00b
 
Join Date: Sep 2008
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bpearson is on a distinguished road
I have power coming out of the fuel pump relay

I have power coming out of the fuel pump relay. no power at the fuse. if i hot wire the fuel pump it runs but I am trying to figure out why there is no power at the fuse.
bpearson is offline  
#9 (permalink) Old 10-15-2008, 09:46 PM
n00b
 
Join Date: Oct 2008
Location: Metro Atlanta
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
dvtent is on a distinguished road
Response.....

I have owned my 94 530i for several years and it has been a great car. However, just last week I experienced the same problem you describe. The car was hard to start (starter is strong) and after two or three attempts it would finally kick over and run just fine.

My mechanic diagnosed the fuel pump as the problem and the car has started just fine since replacing it. Hope this helps.
dvtent is offline  
#10 (permalink) Old 02-02-2011, 02:32 PM
n00b
 
Join Date: Jan 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
aaronisaac is on a distinguished road
1994 5251

Hello BEEMER FAM,

I have a 94 525i that wont start, I put a new battery in it and it has gas in.(THE CAR HAS BEEN SITTING FOR A YEAR IN A GARAGE AND IT RAN FINE WHEN IT WAS PARKED)
I checked the fuel pump fuse with test light no power. I hope some1 can help me out with what it could be? I turn the key forward and i hear the fuel pump running in the engine by the firewall on the driver side. Can some1 tell me where the fuel pump relay is so i can check that? (I dont have a repair book for it. I want to keep the car it is in really good condition other then dirty.

Last edited by aaronisaac; 02-02-2011 at 02:35 PM. Reason: spelling
aaronisaac is offline  
#11 (permalink) Old 07-15-2013, 01:37 PM
n00b
 
Join Date: Jun 2013
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Paul967 is on a distinguished road
I had sort of same problem. No power a fuel pump fuse and no spark. It turned out to be the main relay. White relay passenger side black box.
Paul967 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 530i camper1159 5-Series (E12,E28, E34, E39, E60) 3 07-16-2013 06:00 PM
Purchasing 1994 Bmw 530i Scotty Dangles 5-Series (E12,E28, E34, E39, E60) 27 12-05-2004 01:53 AM
1994 530i transmission vibration howarda780 5-Series (E12,E28, E34, E39, E60) 3 08-30-2004 09:10 PM
95 530i (E34) Tire Pressures tezmanian 5-Series (E12,E28, E34, E39, E60) 1 12-05-2003 02:23 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome