1991 E34 Engine wont start after engine swap - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-07-2009, 08:07 AM
n00b
 
Join Date: Dec 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pegasusflash is on a distinguished road
(Thread Starter)
1991 E34 Engine wont start after engine swap

Hi all , I am new on this forum so I hope you can help me. I bought a 1991 520i recently but the engine failed when bringing the car back from the UK, its a M20 engine. I found a replacement engine its a m20 but it came out of a 320i touring car. The engine has been fitted but will not start it looks like there is an imobiliser switched on as the fuel pump wont pump and there is no spark, the factory fitted alarm appears to be working fine and activates and deactivates. I have changed the ecu as well . Your help would be appreciated, as this is driving me insane.!!
pegasusflash is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-07-2009, 08:29 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
Was the donor car running before you swapped the engine.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#3 (permalink) Old 12-07-2009, 08:31 AM
n00b
 
Join Date: Dec 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pegasusflash is on a distinguished road
(Thread Starter)
Yes it was.
pegasusflash is offline  
#4 (permalink) Old 12-07-2009, 08:33 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
Ok why did the original on fail ?

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#5 (permalink) Old 12-07-2009, 09:07 AM
n00b
 
Join Date: Dec 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pegasusflash is on a distinguished road
(Thread Starter)
I think it was the crank shaft bearings failed. Engine had no compression.
pegasusflash is offline  
#6 (permalink) Old 12-07-2009, 09:35 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
Ok, so it ran but not good....back to the transplant, no fuel pump and no spark, crankshaft sensor.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#7 (permalink) Old 12-07-2009, 10:27 AM
n00b
 
Join Date: Dec 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pegasusflash is on a distinguished road
(Thread Starter)
I have two crank shaft sensors and tried both of them on the engine could the two of them be gone?, how do I test them? also the donor engine is from a e30 320i touring car, are the crank pulleys the same on the 3 series engine as the 5 series?, and should I have used the ecu from the donor car it has a different part number han the original one.
Thanks for helping me.
pegasusflash is offline  
#8 (permalink) Old 12-09-2009, 06:13 AM
n00b
 
Join Date: Dec 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pegasusflash is on a distinguished road
(Thread Starter)
You were spot on Marti5 It was the crank sensor, had it plugged in the wrong place, starting now. Thank for you help.
pegasusflash is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
BMW E46 engine wont start nhanvu2 New Members Check In 2 01-25-2010 11:51 AM
Water trouble now engine wont start. Kazzak 3-Series (E36) 15 02-15-2009 09:53 AM
Engine Wont Start tidesrise 3-Series (E46, E90) 9 03-05-2005 11:10 PM
330i Engine Wont Start tidesrise 3-Series (E46, E90) 8 02-25-2005 09:49 PM
1991 318I ENGINE SWAP skoobasam1 3-Series (E21, E30) 4 07-19-2004 11:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome