1991 Bmw 520i E34 problem Please help - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-07-2009, 12:40 PM
n00b
 
rbooth's Avatar
 
Join Date: Feb 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rbooth is on a distinguished road
(Thread Starter)
1991 Bmw 520i E34 problem Please help

Hi people i hope you can help me i have got a 1991 bmw 520i E34 it is running on 5 cylinders at low revs under load but when it gets past 3k it seems to be ok??? any ideas

Please help
rbooth is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-07-2009, 06:32 PM
n00b
 
Join Date: Nov 2008
Location: Ramstein Germany
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ANDO is on a distinguished road
Have you looked at the spark plugs. Had the exact same problem on my '91 525i and found a plug was loose. Clean and tightened and it clear right up.
ANDO is offline  
#3 (permalink) Old 02-08-2009, 12:10 AM
n00b
 
Pazz535i's Avatar
 
Join Date: Feb 2009
Location: Australia
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Pazz535i is on a distinguished road
Send a message via MSN to Pazz535i
it could also be an airflow or fuel issue, i would suggest new fuel filter and air filter..

Love for the BMer


Pazz535i is offline  
#4 (permalink) Old 02-08-2009, 05:56 AM
n00b
 
rbooth's Avatar
 
Join Date: Feb 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rbooth is on a distinguished road
(Thread Starter)
Hi i have just got in the car this morrning and it was difficult to start but when it did get going it was perfect till it got up to temp then it started to run on 5 cyl when the engine is under load.
rbooth is offline  
#5 (permalink) Old 02-08-2009, 06:04 PM
n00b
 
rbooth's Avatar
 
Join Date: Feb 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rbooth is on a distinguished road
(Thread Starter)
I have looked at the air filter and it is fine i have looked all over the internet and it sounds like it might be 1 of the coil packs that is knackerd. is there anyone in manchester that has a spare coil pack so i can test it on mine as i dont have lots on money trying things out.

if so please message me

Thanks

Richard
rbooth is offline  
#6 (permalink) Old 02-10-2009, 05:32 AM
n00b
 
rbooth's Avatar
 
Join Date: Feb 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rbooth is on a distinguished road
(Thread Starter)
Hi me again

My dad has changed the spark plugs while i was at work yesterday and the car run's a lot better but now when stopped at lights or idling you can smell fuel very strong inside the car and from low rmp under load it slightly misfires


Any ideas???


Thanks

Richard
rbooth is offline  
#7 (permalink) Old 02-10-2009, 05:47 AM
n00b
 
Join Date: Nov 2008
Location: Ramstein Germany
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ANDO is on a distinguished road
Try the fuel pressure regulator and/or cleaning the ICV. I am still haveing similar problems with mine and those are my next steps. After doing a lot of research on the forum that is what i came up to try next. The ICV is a PITA to get to get to under the intake manifold. Hope this helps.

Ando
ANDO is offline  
#8 (permalink) Old 02-10-2009, 01:06 PM
n00b
 
rbooth's Avatar
 
Join Date: Feb 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
rbooth is on a distinguished road
(Thread Starter)
Hi could you please tell me where these are located please

i was hoping it was the injector seals
rbooth is offline  
#9 (permalink) Old 02-14-2009, 05:36 PM
n00b
 
Join Date: Feb 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
duggmark is on a distinguished road
Hi All,

Mark here fro Australia. I am having the same issue with mine. It only started about 3 weeks ago after I filled up (the tank was very low). I am thinking it is fuel quality related. I am going to try a fuel system cleaner and then work my way through the fuel filter and then an injector clean. Will let you know how I go.

First time on the site, I am finding it very helpful.

Cheers,

mark
duggmark is offline  
#10 (permalink) Old 08-02-2009, 12:09 AM
n00b
 
Join Date: Jul 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cressidom is on a distinguished road
Try this - hope it helps

Rbooth / Duggmark,

if you have not done so - please try it !! It sounds like the troubles I've been having since 3 yrs ago - when I got the car,same 520i M50 engine.
Just to recap - feels like it's running on 5 cyls, when it's cold it fine when temp is up crappy idling etc. I take it the fuel consumption has been affected.
Now for the Co2 adjustment..only way is to hook up modic II and have that setting in the ECU re-adjusted.IF you have starting problems (difficult) and
moving off in 1st gear -where it seems like hesitation on the border of stalling - then it's most definitely what I had. A CRAPPY Carbon Canister / Charcoal Canister. Remove the hose from the fuel tank that leads IN to the canister, bypass the canister / eleminate it run the hose directly into the purge valve, the other end of tube remains going into the TB.
Try that and see what happens. I did mine a few days ago WORKED Like a CHARM. no more poor starts,takes off from standstill like a grey hound in heat.

I used to have oil in the intake (large amounts) that were also weeping thru the seals (cylinder head) No more..also no more of that engine oil smell in the air after you've driven it hard.

it's great my FC has improved big time. Try it chaps..I hope it works for you.

Cheers
Dom
Cressidom is offline  
#11 (permalink) Old 05-04-2010, 11:31 PM
n00b
 
Join Date: May 2010
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mrpuffin708 is on a distinguished road
can anyone show me where the charcoal cannister is and where the purge valve is. i just got my 90 525 and it has the worst acceleration of any car i have owned. i know it should be better than that cause i have owned two 90 325. i have a lot of problems and need a lot of parts. any help would be greatly appreciated
mrpuffin708 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
BMW 520i E34 Owner Drabzz New Members Check In 4 06-27-2008 01:47 PM
newbie E34-520i (1991) schematic 5-Series (E12,E28, E34, E39, E60) 10 03-20-2006 09:12 AM
Online Manual For A Bmw 520i E34? bmw520i 5-Series (E12,E28, E34, E39, E60) 1 06-18-2005 03:46 AM
Problem With Speedo On 1991 E34 535i ben_t 5-Series (E12,E28, E34, E39, E60) 0 12-29-2004 01:51 AM
Problem With New Hartge Chip On E34 520i shahnaz 5-Series (E12,E28, E34, E39, E60) 1 10-15-2004 12:27 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome