1990 BMW 525i m20 2 problems? - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-15-2006, 04:03 PM
n00b
 
Join Date: Nov 2004
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Duanevw is an unknown quantity at this point
(Thread Starter)
1990 BMW 525i m20 2 problems?

Hello again members, My 1990 BMW 525 i has 2 problems I have a high idle after the engine is warmed up idle is around 1000-1200 and when it is cold it seems to idle fine maybe a little lower than normal any suggestions? The idle doesn't seem to hunt up or down.

The second problem is the heater always outputs heat to the passenger vents and I replaced the heatervalve and still have the same problem. What is the best way to check for the problem. It has the regular 3 dial knobs for the heater controls.

The car has 204,000 miles

Thanks

Duane MI
Duanevw is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1990 525i e34 vibration / shaking at around 80km/h (50mph) stonedewok 5-Series (E12,E28, E34, E39, E60) 2 11-17-2005 03:12 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome