03 525 it parking sensors problem - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-01-2007, 09:55 PM
n00b
 
Join Date: Oct 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
yokopol is on a distinguished road
(Thread Starter)
03 525 it parking sensors problem

Have some problems with parking sensors ( front and rear) in 2003 525 wagon. They stopped working :-( Problem is that when I press PDC button I can hear long beep and thats it. Light on the button is not coming on. Can anyone help ? Trying to locate fuse for it and can not find it. Maybe someone know where the pdc module is located ?
yokopol is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-04-2007, 10:57 PM
n00b
 
BMWluke's Avatar
 
Join Date: Jan 2006
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMWluke is on a distinguished road
Pdc

Hey there,
On your BMW I believe the PDC Control unit is located on the passanger rear. I would check wire connections on each sensor first.
Hope you find your problem...

Luke
BMWluke is offline  
#3 (permalink) Old 10-05-2007, 09:09 PM
n00b
 
Join Date: Oct 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
yokopol is on a distinguished road
(Thread Starter)
will try

found one bad sensor, hope it helps.
but light on my pdc control button is not blinking at all. maybe my module is dead :-)
yokopol is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic Idle / Misfire / Cutting out makdolby 3-Series (E36) 12 02-05-2012 08:57 AM
528i Alarm Problem Xero 5-Series (E12,E28, E34, E39, E60) 5 01-03-2011 02:16 PM
Climate control unit power problem.. help!? gfowler 3-Series (E36) 3 05-10-2007 12:13 AM
Brakelight problem....really sucks c0de.m3 3-Series (E36) 9 03-05-2007 08:39 PM
Smg Problem On 330i johanfunsale 3-Series (E46, E90) 0 02-28-2005 08:33 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome