02 540i - battery or alternator?? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-21-2010, 06:47 PM   #1 (permalink)
n00b
 
Join Date: Feb 2010
Car:
Posts: 7
Photos:
Bimmerrules is on a distinguished road
02 540i - battery or alternator??

Yesterday coming back from the bay area I noticed the battery light on the dash going on and off and later it stayed on. The car was driving fine and I made several stops turning the car on and off without a problem but the light would not go off. I went to work and stopped the car for about 4 hours. Once I got back in the car to my surprise it turned on without a problem but the battery light remained on. I ran some errands and no problems, turned the car on and off just fine. On my way back home, about a block from my house a bunch of lights went on in the dash and after that I felt as if the transmission jumped and a warning popped up in the dash reading "trans fail safe". At that point it felt as if it was on 3rd gear only. I made it home and turned the car off and tried to turned on right after and it would not fire. The weird part is that the alarm and door locks works fine. Just now I went out to try and turn the car on again and I unlocked the car with the remote key just fine but the car will not fire up. Help please!!
Does anyone have an idea as to why this is happening?
Thanks in advance!
Bimmerrules is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2010, 06:59 PM   #2 (permalink)
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Car: 88 super ETA, 95 525i
Posts: 1,494
Photos:
darkhorse737 is on a distinguished road
Unhappy

1) check all fuses first.

2) have battery checked to see that it is accepting a charge and there are no dead cells;

3) if 1 & 2 are good, then alternator failed.

* in most cases it is #3.

and yes, car will not start when voltage drops below the 10.5 volt level. injectors fuel pump and a host of other electrics are disabled
darkhorse737 is offline   Reply With Quote
Old 02-21-2010, 07:14 PM   #3 (permalink)
n00b
 
Join Date: Feb 2010
Car:
Posts: 7
Photos:
Bimmerrules is on a distinguished road
Thanks for the reply! I will try your suggestions and post the results.
Bimmerrules is offline   Reply With Quote
Old 02-21-2010, 09:41 PM   #4 (permalink)
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Car:
Posts: 1,052
Photos:
Dirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond repute
Quote:
Originally Posted by darkhorse737 View Post
1) check all fuses first.

2) have battery checked to see that it is accepting a charge and there are no dead cells;

3) if 1 & 2 are good, then alternator failed.

* in most cases it is #3.

and yes, car will not start when voltage drops below the 10.5 volt level. injectors fuel pump and a host of other electrics are disabled
agreed
__________________
DT




Dirty_Tool is offline   Reply With Quote
Old 04-01-2010, 10:29 AM   #5 (permalink)
n00b
 
Join Date: Feb 2010
Car:
Posts: 7
Photos:
Bimmerrules is on a distinguished road
Thank you guys very much!!! It was the alternator. Got one at autopartswarehouse.com for a decent price. Thanks for the help!!!
Bimmerrules is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Or Alternator? SUPER_SPORT 3-Series (E36) 4 01-23-2010 12:15 AM
alternator or battery moe_j 3-Series (E36) 6 03-06-2006 04:01 PM
e39 540i alternator and battery question HardStep 5-Series (E12,E28, E34, E39, E60) 5 10-11-2005 12:18 PM
Battery Or Alternator? sennis 3-Series (E36) 13 02-21-2005 05:33 PM
Battery/alternator problems w1sdom Bimmer Talk/Motorsports Talk 1 06-05-2004 02:57 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:50 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.