Yellow Oil Light On, But Oil Level Is Perfect - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-27-2005, 11:24 AM
n00b
 
Join Date: Dec 2004
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bbensten is an unknown quantity at this point
(Thread Starter)
I just changed the oil and reset the service lights on my 2001 325i. Now the yellow oil level light comes on for 10 seconds after I start the car and then turns off. It does not come back on the entire ride in the car but if I turn the engine off and restart it, sure enough it comes back on for 10 seconds... Anyone seen this? Anyone have any ideas? The oil level is perfect.
bbensten is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-27-2005, 01:15 PM
3rd Gear Member
 
Join Date: Aug 2003
Location: Baltimore MD
Posts: 729
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
peterkulesza is an unknown quantity at this point
have it checked out. pump may be failing, and you are not getting enough pressure.
peterkulesza is offline  
#3 (permalink) Old 02-27-2005, 03:55 PM
1st Gear Member
 
storme's Avatar
 
Join Date: Jan 2005
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
storme is an unknown quantity at this point
I AGREE,,,pump might be failing or maybe the oil is wrong viscosity??? wrong oil maybe??

here in the uk,,,the bmw recommende is castrol longlife SLII 0w 30 or 5 w 30...

visit me at <a href='http://www.storme.co.uk' target='_blank'>www.storme.co.uk</a>

visit me at http://www.janspeed.com
storme is offline  
#4 (permalink) Old 02-27-2005, 08:32 PM
5th Gear Member
 
325isBaby's Avatar
 
Join Date: Jul 2004
Location: Spokane, WA
Posts: 1,003
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
325isBaby is on a distinguished road
Send a message via MSN to 325isBaby
Actually it's probably more likely that the LCM needs to be re-programmed. There is an SI out on the subject. Did 2 E46 LCM recodes this week for the same situation. Situation was corrected after the recode.

http://www.myspace.com/330xigirl
Come see me at MySpace
325isBaby is offline  
#5 (permalink) Old 02-27-2005, 09:14 PM
n00b
 
Join Date: Dec 2004
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bbensten is an unknown quantity at this point
(Thread Starter)
Quote:
Originally posted by 325isBaby@Feb 27 2005, 08:32 PM
Actually it's probably more likely that the LCM needs to be re-programmed. There is an SI out on the subject. Did 2 E46 LCM recodes this week for the same situation. Situation was corrected after the recode.
[snapback]300610[/snapback]
Are there any other signs presented by the LCM needing to be reprogramed? Is it just a reset or an upgrade? If I take it to the dealer, I am going to need to know exactly what to ask for so I dont get taken. Thanks for all the help!
bbensten is offline  
#6 (permalink) Old 02-27-2005, 09:28 PM
5th Gear Member
 
325isBaby's Avatar
 
Join Date: Jul 2004
Location: Spokane, WA
Posts: 1,003
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
325isBaby is on a distinguished road
Send a message via MSN to 325isBaby
Have a tech check it out...the SI I refer to states that the LCM needs to be reprogrammed in the situation you are refering to (basically it puts the LCM to the next software level) OR that the oil level sensor has become contaminated and to clean the sensor and then reprogram the LCM. Present what you have to us to your service writer and have a BMW Certified tech check it out. They will be able to determine which situation of the SI you need.

http://www.myspace.com/330xigirl
Come see me at MySpace
325isBaby is offline  
#7 (permalink) Old 02-27-2005, 09:37 PM
n00b
 
Join Date: Dec 2004
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bbensten is an unknown quantity at this point
(Thread Starter)
TSB 110703 MAR 04 Campaign - Engine Low Oil Level Warning

What does the "campaign" part mean? My car is out of warrenty, is this going to cost me? Should I attempt to clean the sensor first? Should I just replace the sensor?
Thanks,
Brent
bbensten is offline  
#8 (permalink) Old 02-27-2005, 09:52 PM
5th Gear Member
 
325isBaby's Avatar
 
Join Date: Jul 2004
Location: Spokane, WA
Posts: 1,003
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
325isBaby is on a distinguished road
Send a message via MSN to 325isBaby
You would have to have someone look at it to be honest with you...chances are like I have told you that the LCM will have to be reprogrammed....we are looking at the same SI...and a campaign is a BMW term for what we are doing to fix this concern basically. Unfortunatly I do not have the ability to let you know how much (or if any) the dealer will charge for the diag and correction. you don't have to replace the sensor in any case.

http://www.myspace.com/330xigirl
Come see me at MySpace
325isBaby is offline  
#9 (permalink) Old 02-28-2005, 08:57 AM
Neutral Member
 
Howie's Avatar
 
Join Date: Feb 2005
Location: Southampton, UK
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Howie is an unknown quantity at this point
Quote:
Originally posted by bbensten@Feb 27 2005, 04:24 PM
I just changed the oil and reset the service lights on my 2001 325i. Now the yellow oil level light comes on for 10 seconds after I start the car and then turns off. It does not come back on the entire ride in the car but if I turn the engine off and restart it, sure enough it comes back on for 10 seconds... Anyone seen this? Anyone have any ideas? The oil level is perfect.
[snapback]300321[/snapback]
I am having exactly the same problem. I topped my oil up as it was getting low and the yellow light was on, but now it keeps coming on, even though the oil level is fine. Its going in for its inspection II in 5 days so will ask and post a reply.
Howie is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
"help! I Want Better Headlights On My 3er!" jlevi 3-Series (E46, E90) 55 11-19-2012 02:23 PM
yellow engine oil mark... Hot Sauce 3-Series (E46, E90) 4 11-02-2005 01:08 PM
Oil Level Light Jag 3-Series (E46, E90) 3 08-16-2005 12:52 PM
Yellow Oil Level Light Comes On Then Goes Off bbensten 3-Series (E36) 7 02-27-2005 06:22 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome