Weird Problem, Please Help! - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-05-2004, 09:37 AM
n00b
 
Join Date: May 2004
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sunjazz is an unknown quantity at this point
(Thread Starter)
I've never seen this problem before...it must be trying to tell me something.

Symptoms:
-The LED display (the one that displays mileage, temp, etc.) is remaining on after the car is off with the key out.
-The lights in the dash that elluminate the symbols around the headlight switch also stay on.
-None of the remote functions on my keys function any longer.

What I've tried:
-Disconnected negative side of battery, reconnected. Problem seemed to go away; keys worked again, dash lights were out, that is, until I turned the ignition switch on and all the problems came back. ghead

Also FYI, my inspection reminder is -700 miles overdue (not sure if this has any bearing on the situation).

Any suggestions...greatly appreciated.
sunjazz is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-05-2004, 11:52 AM
ex owner/admin
 
Furious's Avatar
 
Join Date: Nov 2002
Location: Toronto-Canada
Posts: 10,839
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious Furious
Send a message via AIM to Furious
when you go to get your inspection done, id get that looked at, im not familiar with that problem but maybe the GT1 can find your problem

Furious is offline  
#3 (permalink) Old 10-06-2004, 07:57 AM
n00b
 
Join Date: May 2004
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sunjazz is an unknown quantity at this point
(Thread Starter)
C'mon guys. I'm really not excited about dishing out money at the stealership. Anyone have any ideas on how to troubleshoot this problem?
sunjazz is offline  
#4 (permalink) Old 10-21-2004, 07:45 PM
n00b
 
Join Date: Oct 2004
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
boxxer is an unknown quantity at this point
I'm having the exact same problem with my car. I've traced it back to the ignition switch, the accessoies wire stays hot even when the key is out of the ignition. I just went into the dealership today to order a new switch and they told me that there might me a small change that it might be a problem with the barrel or the cylinder. I don't know if i believe them, I think they are just after my money. So I'm going to take the whole ignition apart just to see.
boxxer is offline  
#5 (permalink) Old 10-25-2004, 09:28 AM
n00b
 
Join Date: Oct 2004
Location: The Big Smoke......LONDON!
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Marauder is an unknown quantity at this point
Hey SunJazz
having the exaclty the same problems and some, my car is in again, will find out what they've done and get back too you if they've solved it.....THEY BETTER!

Look at thread today 'Comp Gone Mad'

Out of curiousity, what year and model do you have?
Marauder is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Lighter Plug Problem maxxym 5-Series (E12,E28, E34, E39, E60) 4 04-12-2012 06:20 AM
Weird E34 540 tranny problem, help needed.. antose9 5-Series (E12,E28, E34, E39, E60) 8 11-08-2005 11:43 PM
Need Help! Power Drain Problem 95 540i E34 newdad52001 5-Series (E12,E28, E34, E39, E60) 2 12-07-2004 07:33 AM
Help! Weird Idle Problem t-im 3-Series (E36) 0 09-25-2004 11:36 PM
Strange AC Vent problem E60 ... Help! yates88m5 5-Series (E12,E28, E34, E39, E60) 2 07-24-2004 02:57 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome