trip computer etc not working - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-03-2011, 01:15 PM
5th Gear Member
 
jimmythepie's Avatar
 
Join Date: Jan 2007
Location: england
Posts: 1,118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jimmythepie jimmythepie jimmythepie jimmythepie
(Thread Starter)
trip computer etc not working

the trip computer on my faithful e-46 has stopped working, this means no temperature readout etc. Anybody got any ideas on how I can get it working again.

Thanks the help Jimmy
jimmythepie is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-03-2011, 01:58 PM
Captain... Savvy ?
 
Jack Dabsy's Avatar
 
Join Date: Apr 2011
Location: Barnsley UK
Posts: 2,194
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Jack Dabsy will become famous soon enough
Garage
Usually, unplugging and replugging sorts it out... BUT...
Check all fuses because it IS electrical.
HTH DAZ
Jack Dabsy is offline  
#3 (permalink) Old 05-03-2011, 02:00 PM
Captain... Savvy ?
 
Jack Dabsy's Avatar
 
Join Date: Apr 2011
Location: Barnsley UK
Posts: 2,194
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Jack Dabsy will become famous soon enough
Garage
Please come back to me on this one Jim...
It is the dot matrix computer, yes?
DAZ
Jack Dabsy is offline  
#4 (permalink) Old 05-03-2011, 02:10 PM
5th Gear Member
 
jimmythepie's Avatar
 
Join Date: Jan 2007
Location: england
Posts: 1,118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jimmythepie jimmythepie jimmythepie jimmythepie
(Thread Starter)
hello mate, thanks for your input, when you say unplugging and re-plugging sorts it out, I don't get what you mean to unplug. When it first stopped working everything but the temperature gauge disappeared, pressing the end of the stalk which used to switching between the different things stopped working. I put a new battery on the car and everything stopped working.

I'm afraid I don't know what a dot matrix computer is, the car is a 1998 E 46 saloon car. As far as I remember it was a standard computer on that model, you used to press the end of the stalk to get mileage readout, temperature etc.

Thanks again Daz
jimmythepie is offline  
#5 (permalink) Old 05-03-2011, 02:32 PM
Captain... Savvy ?
 
Jack Dabsy's Avatar
 
Join Date: Apr 2011
Location: Barnsley UK
Posts: 2,194
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Jack Dabsy will become famous soon enough
Garage
My mistake, Jim... You are talking about the dashboard (Clocks) computer as opposed to the centre console display...
In this case it is also electrical and please check fuses etc. 1st...
If all ok then it could be a Dash-out situation where either that fat capacitor/regulator has failed on the rear of the clocks, OR a simple OBD2 reset (Tool or Diagnostic laptop required).
To expand on this - has most if not all information dissappeared?
If ALL then its the clocks...
If SOME then it could be the ribbon that feeds the display (This could also be the cause of the aforementioned)...
In my honest opinion, looks like a OBD2 test... At least if you have it checked, it would still come up with values even if the clocks are dead!
Be very careful if you change the clocks tho, as the new clocks will not match the ECU therefore you will see a dot near the milage indicating that it does not match the car...
One step at a tim though Jim, eh?
Jack Dabsy is offline  
#6 (permalink) Old 05-03-2011, 02:51 PM
5th Gear Member
 
jimmythepie's Avatar
 
Join Date: Jan 2007
Location: england
Posts: 1,118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jimmythepie jimmythepie jimmythepie jimmythepie
(Thread Starter)
the mileage is still displayed and the trip milometer is still working. The stuff that isn't working is the readout you get from the little trip computer. To reiterate, everything except the temperature gauge stopped working some time ago, I wasn't too bothered but when I put a new battery on even the temperature gauge has given up the ghost. Now all I get in the readout box is a series of dashes like you used to get when you were zeroing something.

If it was a fuse surely everything on there would have stopped working including the temperature readout. I know this is a real pain in the arse but thanks for your help daz.
jimmythepie is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trip Computer Agent Orange 3-Series (E21, E30) 1 02-26-2005 06:05 PM
Trip Computer Reset 540sport 5-Series (E12,E28, E34, E39, E60) 6 01-02-2005 12:53 AM
BMW trip computer CarpentersLocal2018 3-Series (E46, E90) 0 08-08-2004 10:44 PM
Can't get my trip computer working '84 325e Tadao 3-Series (E21, E30) 4 01-06-2004 07:27 PM
Trip computer not working in 88 735i ericesquire 1,6,7,8 - Series and Mini Cooper 0 12-10-2003 06:24 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome