Sulfer When Idling Or Turning Car Off - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-30-2005, 01:04 AM
1st Gear Member
 
BMW-ATI's Avatar
 
Join Date: Nov 2004
Posts: 326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMW-ATI is an unknown quantity at this point
Send a message via AIM to BMW-ATI
(Thread Starter)
I talked to a "NAPA" auto parts mechanic LOL
because my car has been laggy and just RPM's going everywhere and I began to smell a strong strong sulfer smell today EWW whern i was idling in the hot sun or when i turned the car off, it just kinda did it in the morning, but is this possibly an 02 sensor?
BMW-ATI is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-30-2005, 10:51 AM
1st Gear Member
 
BMW-ATI's Avatar
 
Join Date: Nov 2004
Posts: 326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BMW-ATI is an unknown quantity at this point
Send a message via AIM to BMW-ATI
(Thread Starter)
anyone!?
BMW-ATI is offline  
#3 (permalink) Old 07-30-2005, 02:24 PM
2nd Gear Member
 
zibby's Avatar
 
Join Date: Dec 2004
Location: Vancouver, Canada
Posts: 507
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
zibby is an unknown quantity at this point
Quote:
Originally posted by BMW-ATI@Jul 30 2005, 10:51 AM
anyone!?
[snapback]366239[/snapback]
Looks like catalitic convertor is gone- rotten eggs odour(just assuming), might be also oxygen sensor problem(pre-catalist)
zibby is offline  
#4 (permalink) Old 07-30-2005, 09:07 PM
2nd Gear Member
 
zibby's Avatar
 
Join Date: Dec 2004
Location: Vancouver, Canada
Posts: 507
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
zibby is an unknown quantity at this point
One more question-what brand of gasoline do you use ? did you recently change the brand of gasoline ? if yes switch brands until you get one that works. It may take 2-3 tankfuls to know. Some gasolines have high sulphur content , that also can cost the problem !
zibby is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Car lurches intermittently when A/T shifts wango 3-Series (E36) 2 10-31-2005 03:28 PM
Chip Made My Car Slower gonzonick 3-Series (E36) 12 10-25-2005 02:46 PM
problems starting car when cold... VLAD_325is 3-Series (E36) 8 09-12-2005 08:08 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome