serious electronis(?) problem - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-07-2004, 12:03 AM
1st Gear Member
 
gonzo499's Avatar
 
Join Date: Feb 2004
Location: slc, utah
Posts: 257
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
gonzo499 is an unknown quantity at this point
(Thread Starter)
i first noticed the problem when i turned down my ac and three seconds later it went back up again. three seconds after that it went went back to what i adjusted it to.
shortly thereafter i turned left and noticed my left turn signal wasn't working. not at all. no flasher on the cluster, no signal light, nothing. right signal either. they still do not work.


i then did a quick check on everything and found the following problems:
-seatbelt light doesn't turn off when buckled.
-clock button(and only the clock button) doesn't work on my stereo
-the door ajar indicator only works sometimes.
-the traction control exclamation point indicator turned on for a while on its own.
-at first the inst cluster wouldn't light up completely(it was very dim with roller knob at full) when i turned the lights on.


these things seemed unaffected however:
-button on end of turn signal
-all lights not on the dashboard
-mirrors
-alarm including corners and side markers when alarm engages/disengages
-ordinary driving operations.



there may be a few more things that i've forgotten but you get the idea.it seems like a serious problem- if anyone has some insight i'd appreciate it.
thanks

<img src='http://www.bmw-forums.com/forum/uploads/post-4-1081744190.jpg' border='0' alt='user posted image' />
<span style='color:gray'><span style='font-family:Arial'>2000 323Ci alpine white</span></span>
gonzo499 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-08-2004, 07:39 PM
1st Gear Member
 
gonzo499's Avatar
 
Join Date: Feb 2004
Location: slc, utah
Posts: 257
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
gonzo499 is an unknown quantity at this point
(Thread Starter)
its now been two days and i noticed that the signals actually work (and probably have worked the whole time), its just the signal indicator arrows that do not work. the dsc light still turns off and on at its own leisure-which is nice. the ac doesn't work even though the snowflake light is on(blows hot air) and the door open indicator still works only when it feels like it. someone? anyone? my appointment isn't until the end of next week. if anyone has a clue please fill me in.

<img src='http://www.bmw-forums.com/forum/uploads/post-4-1081744190.jpg' border='0' alt='user posted image' />
<span style='color:gray'><span style='font-family:Arial'>2000 323Ci alpine white</span></span>
gonzo499 is offline  
#3 (permalink) Old 07-09-2004, 08:49 AM
1st Gear Member
 
Join Date: May 2004
Location: Seattle, WA
Posts: 262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
KillFox is an unknown quantity at this point
Send a message via AIM to KillFox Send a message via Yahoo to KillFox
Check your fuses?

<img src='http://3dwire.net/~matt/killfoxsig2.gif' border='0' alt='user posted image' />
KillFox is offline  
#4 (permalink) Old 07-10-2004, 09:49 AM
2nd Gear Member
 
EXtech's Avatar
 
Join Date: Jul 2003
Location: Texas
Posts: 497
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
EXtech is an unknown quantity at this point
Sounds like you need a new cluster. Yes, the entire instrument cluster. They aren't cheap either. But I would have the dealership hook it up to the diag machine to determine exactly. There's also a chance it could be a general module but then you would most likely have problems with many other things. There is a slight chance that it could just be a bad connection on the back of the cluster but I would lean more to a faulty unit. Hopefully you have some warranty left.

STETT Performance -
Everything BMW
921 J Place, Suite 200
Plano, TX 75074
469-767-3309

OEM Repairs and Maintenance
Extended Warranty Service
Pre-Purchase Inspections
Everything Performance (brakes, turbos, Nitrous, Cams, Complete Engines, Clutches/Flywheels etc)
-----------

STETT Performance Official Grand Opening BMW Meet, May 6th 11A-3P -- Music, Food, Drawings and Tons of BMW's go to http://206.123.107.13/stett and register.. it's FREE
EXtech is offline  
#5 (permalink) Old 07-19-2004, 09:17 PM
1st Gear Member
 
gonzo499's Avatar
 
Join Date: Feb 2004
Location: slc, utah
Posts: 257
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
gonzo499 is an unknown quantity at this point
(Thread Starter)
good call. i need a new cluster. thanks for the warning, it's a little easier to get a six hundred dollar bill if you know it's comin.

<img src='http://www.bmw-forums.com/forum/uploads/post-4-1081744190.jpg' border='0' alt='user posted image' />
<span style='color:gray'><span style='font-family:Arial'>2000 323Ci alpine white</span></span>
gonzo499 is offline  
#6 (permalink) Old 07-19-2004, 10:01 PM
2nd Gear Member
 
EXtech's Avatar
 
Join Date: Jul 2003
Location: Texas
Posts: 497
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
EXtech is an unknown quantity at this point
I'm glad I could help.. and glad you got it fixed.

STETT Performance -
Everything BMW
921 J Place, Suite 200
Plano, TX 75074
469-767-3309

OEM Repairs and Maintenance
Extended Warranty Service
Pre-Purchase Inspections
Everything Performance (brakes, turbos, Nitrous, Cams, Complete Engines, Clutches/Flywheels etc)
-----------

STETT Performance Official Grand Opening BMW Meet, May 6th 11A-3P -- Music, Food, Drawings and Tons of BMW's go to http://206.123.107.13/stett and register.. it's FREE
EXtech is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Serious Problem With My Breaks Pro-Hunter 1,6,7,8 - Series and Mini Cooper 2 06-21-2005 06:42 PM
Smg Problem On 330i johanfunsale 3-Series (E46, E90) 0 02-28-2005 07:33 AM
Serious problem with the rear suspension... rauljulian 3-Series (E36) 4 11-26-2003 06:08 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome