PLEASE HELP PROBLEM W/My 330ci - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Closed Thread
 
LinkBack Thread Tools Display Modes
Old 12-07-2007, 01:38 AM   #1 (permalink)
n00b
 
Join Date: Dec 2007
Car:
Posts: 13
Photos:
Christian.park07 is on a distinguished road
PLEASE HELP PROBLEM W/My 330ci

Ok guys/ girls... i really need help here. I just joined the E46 class crew.=) But im having this problems with my car already. Please help if you have ever heard of such a problem.

It happens every now and then... first make a model. Bmw 330ci 2001 auto.
When im at a stop, sometimes i mean sometimes the car stalls out and stops running. I have to stick it back in Neutral and then start the car again. Sometimes it has a hard time starting and when it does, i stick it back into drive and accelerate it shuts off again. This happens every so often.

Also when im driving it sounds like the intake is trying to suck alot of air which gets louder and then accelerates hard. like lagg or some what.

anyone heard of this problem or even experienced this problem please help me! i dont want to spend thousands of dollars taking into BMW and them ripping me off.

Comments feedback would be great Thanks guys/gals
Christian.park07 is offline  
Sponsored Links
Advertisement
 
Old 12-07-2007, 08:12 AM   #2 (permalink)
1st Gear Member
 
chinonca's Avatar
 
Join Date: Dec 2007
Car:
Posts: 207
Photos:
chinonca is on a distinguished road
Stall problem

First of all do you have a check engine light on??? Next when was the last time you did a tune up!?
chinonca is offline  
Old 12-07-2007, 08:13 PM   #3 (permalink)
n00b
 
Join Date: Dec 2007
Car:
Posts: 13
Photos:
Christian.park07 is on a distinguished road
bmw

Quote:
Originally Posted by chinonca
First of all do you have a check engine light on??? Next when was the last time you did a tune up!?

Um no i dont have a check engine light on. I just have a service engine check light that came on. Im kinda new to BMW's so i dont really know if they is considered check engine light. Last time i did a tune up was 130xxx.
Christian.park07 is offline  
Old 12-07-2007, 08:20 PM   #4 (permalink)
1st Gear Member
 
chinonca's Avatar
 
Join Date: Dec 2007
Car:
Posts: 207
Photos:
chinonca is on a distinguished road
you need to get that service engine light checked out to see what code the ecm is logging, after you find out the code you will have an idea of what is going on with her!
chinonca is offline  
Old 12-08-2007, 10:30 PM   #5 (permalink)
n00b
 
Join Date: Sep 2007
Car:
Posts: 2
Photos:
m2fm2 is on a distinguished road
you need to get the code read to help pin pont the problem. hard to diagnose over the web. but off hand it sounds like a vacuum leak or maybe a bad MAF?
m2fm2 is offline  
Old 12-08-2007, 11:55 PM   #6 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
bad spark plug wire(s) maybe shorting? plugs? coil could be dieing?
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
Old 12-09-2007, 02:09 AM   #7 (permalink)
WOT in Reverse
 
jllphan's Avatar
 
Join Date: Jan 2004
Location: Cashville, TN
Car:
Posts: 3,441
Photos:
jllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond reputejllphan has a reputation beyond repute
Send a message via AIM to jllphan
is it ever tough to start? or does it start every time? if so, it's probably the cam sensor. if not, it could be a lot of things. best to take it to your local tech and have them read your fault codes, should give you some indication of the issue. hope this helps
__________________
jllphan is offline  
Old 01-02-2008, 05:17 PM   #8 (permalink)
n00b
 
Join Date: Feb 2007
Car:
Posts: 5
Photos:
PIMPO is on a distinguished road
The only thing i can think of with the intake noise is that the fan clutch can be getting stuck!

If so, it could break your fan blades off then break pretty much everthing in the front of the engine.

Coolant systems suck for e46
happened to me and was very expensive to fix.
PIMPO is offline  
Old 10-13-2010, 06:55 AM   #9 (permalink)
n00b
 
Join Date: Oct 2010
Location: Savannah Ga
Car: 04 330ci supercharged, lowered
Posts: 24
Photos:
blown330ci is on a distinguished road
Garage
Check for leaking intake gasket.
blown330ci is offline  
Old 10-13-2010, 09:08 AM   #10 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
The OP is from 2007
__________________
BMW

Sig by zeaq
witeshark is offline  
Sponsored Links
Advertisement
 
Closed Thread

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Desperately Need Your Help: BMW325i "Service Engine Soon" light problem CNMB250 3-Series (E46, E90) 4 12-19-2007 06:26 AM
330Ci Power loss Blue Ninja 3-Series (E46, E90) 6 02-18-2007 08:26 PM
E34 trans prog problem exacerbated electronblue 5-Series (E12,E28, E34, E39, E60) 5 03-02-2006 10:07 PM
330CI LED Tail light conversion problem kwoktoa 3-Series (E46, E90) 2 02-05-2004 07:47 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:51 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.