Intrument indicator lights. - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-27-2007, 03:27 PM   #1 (permalink)
n00b
 
Join Date: Apr 2004
Car:
Posts: 24
Photos:
lalvevo is an unknown quantity at this point
Intrument indicator lights.

Hi all, I have a e46 2000 323ci convertible and my turn indicator light+clicking sound on my dash is not working. But all the lights still lights up outside. and same problem for my high beam and fog lights, they work fine but doesnt show anything on my dash. Also my convertible top won't come down! I've checked all the fuses and they are fine. And I brought it to this local mechanic down the street and they told me to bring it to them tomorrow morning and they said they might have to rip out the whole cluster to see whats wrong with the lights and said something about "there's a saftey feature" for the convertible top to stop it from working, and would probably take couple hours. Does anybody knows what's wrong and if its easy to fix? Cause I don't want to pay couple hours of labor if its an easy thing to fix. Thanks all!
lalvevo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-01-2007, 11:42 PM   #2 (permalink)
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Car:
Posts: 1,052
Photos:
Dirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond repute
Did you get it taken care of already?
__________________
DT




Dirty_Tool is offline   Reply With Quote
Old 03-02-2007, 04:44 AM   #3 (permalink)
n00b
 
Join Date: Apr 2004
Car:
Posts: 24
Photos:
lalvevo is an unknown quantity at this point
i brought it back to that place and they checked it out for an hour and didnt charge me for that and said my control unit/computer needs to be replaced cuz its burnt and melting. and he called bmw for the CU and it cost $400 from dealer and its a special order and have to wait 2-3days. so he told me it would cost me total of $600 for that unit and diagnostic. dunno if they over charged me or not but it needs to be fixed. im also worring if it needs to be recoded or programming my key/remote or something from bmw. that problem that i had is pretty weird, it was like some1 in the CU just shutting down each section, like my alarm, it was working fine wen i came out of my house then wen i got to the mechanic and i lock my car, the lights dont blink but it will have the chirp sound. i really like this car and dont wanna let go. now i have to walk in this rain/sleet/snow here in MA and probably not gonna be fixed until mon or tues.

Last edited by lalvevo; 03-02-2007 at 04:55 AM.
lalvevo is offline   Reply With Quote
Old 03-26-2007, 03:28 PM   #4 (permalink)
n00b
 
Join Date: Apr 2004
Car:
Posts: 24
Photos:
lalvevo is an unknown quantity at this point
Wow I'm finally gonna get my car back tomorrow after having it fix for a month. Thay had to change the ECU and have the dealer reprogramming it. He found out the problem that cause the ECU to burn was the DENSION ICE-LINK IPOD Interface I had. I thought it acts like a CD-Changer and it was plug and play with the pre-wired in the trunk. Does anyone have the ice-link interface and had this problem? Kinda sux buying the ipod interface for like $50 and now I gotta pay $600 for a new ECU and have to eliminate the ipod interface.
lalvevo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:48 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.