I am a new member, and in need of HELP! - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-27-2008, 01:26 AM
n00b
 
Join Date: Nov 2008
Location: SoCal
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bob Rocks is on a distinguished road
(Thread Starter)
Exclamation I am a new member, and in need of HELP!

Hello all. I have recently purchased a good friend's 2003 330Ci and have a few problem's with it. First off, The car has 65k miles, and has a 72 month / 100k mile warrantly that end's on 1-22-09. My friend needed to sell the car for financial reason's, and it has been sitting in the driveway for 5 month's.
I took the car into service at "New Cewntury BMW" In Alhambra, CA. After they inspected the car, they said it needed a new battery, as well as a new Exterior thermastat sensor. I just paid the $50 warranty fee, and took the car back to replace the battery myself instead of paying the $250 for a battery (Im not worried about the exterior temperature sensor). Today i ahve notice the "Oil presure red light" blinking for just a second when i come to a stop. I oil level is at the max level, and the dealership told me the oil pump was good so it might be a bad "oil pressure sensor". The problem im having is with the AC. The car is set to anywhere betweeen 60-70 degree's F, and i have the "Top, middle, and Bottom" vents blowing. The middle vent blow's cool air, but the top and bottom blow HOT air. My buddy with a 02' M3 told me he had the same problem, and told me to replace my old battery with a new one, and the problem will go away. The 2nd problem is a "poping / Clicking" noise coming from the suspension of the car when i make left/right turn's, or go over bump's. My friend told be he had the same problem on his M3, and it was due to a lose sway bar. The dealership didn't help much because the car is under warranty. They told me the blinking "oil pressure" light is due to a bad battery, and i have no idea what this clicking noise is (i think its coming from sway bar, or lower control arm's) I am going to switch out the battery, and take the car into a diff BMW dealership to have it looked at. Can anyone maybe point out the problem (i know its impossible without inspecting the car), or tell me of an independent BMW specialist in SoCal? The AC isn't working, and almost caused an accidnet tongiht in the rain when it didnt defrost the window's, and this blinking oil pressure light is bugging me. Does the new battery fix the light problem? Please get back to me on this. My car also has a Check engine Light on, but im guessing in need's to be reset, or it's maybe due to a O2 Sensor. My friend know's nothing about car's, and gave it to me for dirt cheap. PLEASE HALP!!!
Bob Rocks is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-27-2008, 10:15 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
Has it had an oil change ??( as the oil goes thick) cars esp BM's dont like sitting around, get the Batt changed and a lot of your problems will go away, as for the suspension its probably a dry joint as again they dont like sitting around.

1. New Battery

2. Full service

The see how it is, if you still have a problem get back to us.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#3 (permalink) Old 11-27-2008, 07:01 PM
n00b
 
Join Date: Nov 2008
Location: SoCal
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bob Rocks is on a distinguished road
(Thread Starter)
Yea, i talked to him and he hasn't changed the oil in 20K!!! Im going to purchase 7qt's, a new filter, as along with a 49-DL battery from autozone, and see what code that SES is. Im still not sure what is wrong with my AC. HVAC control's operate normal, but the hot air blow's from top and footwell vent's, and cool air from the middle vent's....
Bob Rocks is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
new member... jwardmls New Members Check In 3 06-26-2008 09:23 PM
New Member boostinsixtwintturbo M-Series (M1, M3, M5, M6) 6 06-27-2005 11:53 AM
New Member Needs Help M3 Chick M-Series (M1, M3, M5, M6) 3 06-16-2005 12:44 PM
Another New Member timrotor 3-Series (E46, E90) 3 10-27-2004 03:16 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome