Engine turns off when accelerating - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-21-2013, 04:04 PM   #1 (permalink)
spg
n00b
 
Join Date: May 2013
Car:
Posts: 1
Photos:
spg is on a distinguished road
Engine turns off when accelerating

I have a 2003 325i that has been experiencing weird issues. I purchased the vehicle from CarMax in November 2012. The car was running fine, except one incident, close to a month after I purchased it. My boyfriend was driving at the time, and pretty soon after starting his drive (within 2 minutes), the car turned off when he went to accelerate from a full stop. It turned back on right away and there were no other issues, so we didn't do anything about it.

Fast forward to March 2013. I noticed that the car would sometimes shake when it was first turned on. Usually turning it off and starting again would fix this. Then, the car powered off during acceleration again. It happened once for me and a couple more times to my boyfriend. I was also noticing that it sometimes felt like it was going to shut off when I was accelerating, almost like when I had a stick shift and the car was going to stall, but if I gunned it, it would be fine. This had the affect of making the accelerator seem extra touchy. This would go away after driving for a few minutes.

We have a warranty with CarMax and I was planning on taking it in the next time I was able to take a day off of work. Before I could, it happened again, but this time the car did not turn back on.

We had it towed to CarMax and they replaced the fuel pump. It was running fine after that, though it would still occasionally shake when it was first turned on. I figured the issues weren't related, and maybe they aren't.

The same thing happened again last Monday. The car powered off during acceleration, but turned back on. I had it towed to a repair shop (CarMax was booked for weeks) and they couldn't replicate the issue. They tried for a couple of days and weren't able to replicate the problem.

As a fun result, I'm in a battle with CarMax about covering the cost of my rental car.

I've seen similar issues on different threads, but it appears that the engines would stop while they were driving, and not necessarily when accelerating from a full stop.

Does anyone have any advice?
spg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-27-2013, 08:49 AM   #2 (permalink)
4DoorWhore
 
Lord Vader's Avatar
 
Join Date: Feb 2005
Location: Calgary, AB
Car: 1998 E36 328i
Posts: 2,210
Photos:
Lord Vader is on a distinguished road
Welcome to Bimmerwerkz.

Take the car to have the OBD system scanned for trouble codes. Any codes present will identify the problem and help you to fix it.

I would check for vacuum leaks in all your hoses and lines including the intake boot. I would also check your MAF. A bad MAF and the computer doesnt know how much air is getting into the engine and cant compensate properly.
__________________

ProjectTechnik.com - Alberta based BMW Community
See My car on Project Technik HERE!

And Follow Me on Instagram @E36M52

Founding Member of the Canyonrot Club! Paint Code #343

| OE M3 Bumper | M3 Mirrors | Max Velocity GTR Lip | Euro ZKW Projector Headlights | Jim Conforti CF CAI | UUC Motorwerks Underdrive Pulleys | 18x8 ASA AR1's | Koni Sport Springs & Shocks |
Lord Vader is offline   Reply With Quote
Old 12-29-2013, 05:33 PM   #3 (permalink)
n00b
 
Join Date: Dec 2013
Location: Pennsylvania
Car: 2000 323i sedan
Posts: 4
Photos:
clarkmichaelmr is on a distinguished road
I had the same problem. I found my 00 323i did not like regular gas. Mid grade or higher. Also, I replaced my mass air intake sensor and I have never had an issue with this again..
Hope this works for you. It's been a while since you've posted.
clarkmichaelmr is offline   Reply With Quote
Old 03-10-2014, 10:22 PM   #4 (permalink)
n00b
 
Join Date: Mar 2014
Car:
Posts: 1
Photos:
Mclure325 is on a distinguished road
Did you ever fix this problem? The exact same thing is happening to my 05 325i
Mclure325 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
not accelerating jimmye36 3-Series (E36) 3 09-03-2012 08:55 PM
'97 328i looses accelerating power and check engine light comes on? gozbay 3-Series (E36) 10 11-23-2009 06:28 PM
Engine Turns But Will Not Fire E30 320I 3-Series (E21, E30) 9 08-18-2009 03:31 PM
Engine/battery Turns Off miinus 3-Series (E46, E90) 0 10-01-2004 08:21 AM
engine light turns on intermitently YNGRVP 3-Series (E36) 4 06-25-2004 02:01 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:59 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.