e46 intermittent electrical problems - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-18-2008, 05:11 PM   #1 (permalink)
n00b
 
Join Date: Aug 2008
Car:
Posts: 5
Photos:
troppe is on a distinguished road
e46 intermittent electrical problems

I bought a used 2003 330 Convertible a year ago. 3 months ago, I had the alternator light come on. It would come on first time I drove the car, especially with AC on, but would only stay on til the temp gauge hit 3/8. It did not come on every morning...took it to my local bmw guy (non-dealer), and he said it was alternator. Replaced with a rebuilt Bosch, and thought all would be fine. A few days later, the same symptoms occurred. It continued to be random, not even happening each morning. We replaced teh battery.

After the battery was replaced, it was a little better, came on less frequently, and I thought it didn't happen when the AC was off - but recently it occurred when the AC was off as well. One morning last week, instead of the alternator light coming on, the indicator which said my left front headlight was out came on - this time, it was after the car had been running for 3 miles, and late in the day (altho the car was parked all day). I flipped the lights off and on, and it went out.

Since then, I've had the head lamp indicator come on a couple times, and the alternator light come on. This morning. Both came on at the same time. They did not go off when the car temp hit 1/2. I turned the car off (after about 2 miles), and when I restarted it 3 min later, the headlamp indicator was not lit, but the alternator still was. While the car was running for the next 5 min, the alternator light went out, andthe headlamp indicator came back on. The AC was not running except when I started the car the first time - and immediately turned it off.

Any ideas what might be going on here. Is there any good way to diagnose this without replacing all the things that might be symptoms, rather than true cause. All other electrical items seem to be ok. Also, when the headlamp indicator light is on, the headlamp itself if off.
Thanks!
troppe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-18-2008, 11:48 PM   #2 (permalink)
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Car: 88 super ETA, 95 525i
Posts: 1,494
Photos:
darkhorse737 is on a distinguished road
Arrow

what's your RPM when the alternator light comes on?

when A/C kicks in. what is the idle RPM?

when u accelerate, does the alternator light disappear?

(for now i'll consider the headlamp a separate issue.)
darkhorse737 is offline   Reply With Quote
Old 08-19-2008, 06:50 AM   #3 (permalink)
n00b
 
Join Date: Aug 2008
Car:
Posts: 5
Photos:
troppe is on a distinguished road
intermittent electrical

The light sometimes comes on when I am idling in my driveway - or immediately after start. Idle is approx 650 rpms. the light(s) stay on at all rpms, (in automatic mode....having tried with tiptronic shifter on). When temp reaches close to 1/2, light turns on most of time.

As for lights, my BMW service guy thought it may be the light, or the connection, but found that I have Zenon bulbs, so we didn't want to treat a symptom with an expensive part.
troppe is offline   Reply With Quote
Old 08-19-2008, 09:05 AM   #4 (permalink)
5th Gear Member
 
darkhorse737's Avatar
 
Join Date: May 2008
Location: San Francisco, CA
Car: 88 super ETA, 95 525i
Posts: 1,494
Photos:
darkhorse737 is on a distinguished road
Quote:
Originally Posted by troppe View Post
The light sometimes comes on when I am idling in my driveway - or immediately after start. Idle is approx 650 rpms. the light(s) stay on at all rpms, (in automatic mode....having tried with tiptronic shifter on). When temp reaches close to 1/2, light turns on most of time.

As for lights, my BMW service guy thought it may be the light, or the connection, but found that I have Zenon bulbs, so we didn't want to treat a symptom with an expensive part.
if you have a voltmeter/multimeter... or have access to one; measure the voltage of the battery IGNITION OFF(should be no less than 12 volts). Then take a 2nd reading of battery voltage with engine running(should be around 13.8 volts at least). If you achieve these figures, then your prob is in the circuitry of your instrument panel and the electrical system; not in the charging system.

TIP: make sure there are no loose fuses. Go through them 1-by-1 and make certain they are snug.
darkhorse737 is offline   Reply With Quote
Old 08-20-2008, 08:01 PM   #5 (permalink)
n00b
 
Join Date: Aug 2008
Car:
Posts: 5
Photos:
troppe is on a distinguished road
I went thru all the fuses and made sure they were snug. no issues there. Neither of the two lights came on in the last two days, until I had driven the car for 3 times, it had reached the midpoint of temperature. The 3 times driven were within an hour of each other...on the third time, after it had been driven for about 1 mile, and on the highway. I did have the AC on - but also had it on earlier with no incident. Also, I live in NC, and the last few days the humidity has not been unusually high. The previous incidents have been the morning after a rain, or on a foggy morning. The issue today occurred after a rain.
Any ideas for next steps?
troppe is offline   Reply With Quote
Old 11-12-2008, 07:31 AM   #6 (permalink)
n00b
 
Join Date: Aug 2008
Car:
Posts: 5
Photos:
troppe is on a distinguished road
e46 intermittent electrical problems - update

Hi - I've had some work done to this 330 convertible, and may have narrowed the symptoms as a result. I still have an intermittent alternator light come on, and it is on more often than it is off. HOwever, I've had the igniter replaced in the headlamp, and no longer have the headlamp indicator come on. I've also had the alternator and battery replaced, along with the ignition switch. We've checked the codes in the computer and replaced the brake (light) module as well. I've checked the voltage on the battery...when the car is running without the alternator light lit, voltage is ~13.9, when the indicator is lit, it is also 13.9v. When the car is turned off, the battery registers ~12v.

The indicator lamp does not appear to be related to when the AC or climate control is on at all. Also, with the floating battery platform in the convertible, is it possible there's a small short in the cable to the battery, that when that platform 'floats', in causes the problem? I don't think this is the case however, as the indicator light stays lit for a period of time - it does not 'flicker' as I hit bumps in the road.

Given the fact that I've eliminated the headlamp indicator problem, and know the voltage at the battery, are there any new suggestions as to what this could be?

I appreciate your help and ideas! Thanks!
troppe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
E46 intermittent electrical problem troppe New Members Check In 0 08-18-2008 07:01 AM
Z4 problems: electric window, intermittent wipers. xdcam Z3 / Z4 /ZM 2 08-18-2008 06:44 AM
E46 Coupe Intermittent System Fail BONZO 3-Series (E46, E90) 0 02-01-2005 09:24 AM
Intermittent Heater Problems (no Heat) openclassrally 3-Series (E36) 6 01-21-2005 10:23 PM
starting problems intermittent bmwforum 3-Series (E21, E30) 3 06-17-2004 05:34 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:52 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.