e46 cuts out sometimes - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-04-2005, 04:20 PM
n00b
 
Join Date: Dec 2005
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
D4LJE is on a distinguished road
(Thread Starter)
e46 cuts out sometimes

used: i have a 325 coupe e46 with 60,000 miles on the clock, sometimes the car just cuts off while im slowing down and then starts up at the 3 or 4th attempt, Was told it might be the cam shaft sensor, has anybody had the same problem. Ive had it fully serviced and they changed the fuel filter. used: used: used: used:
D4LJE is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-04-2005, 08:11 PM
You Can Has A Custom Title!!
 
Join Date: Dec 2002
Location: Grand Canyon State
Posts: 2,146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AZ325Ci is on a distinguished road
I've had similar problems before, but only at 15-20K miles. The dealer just re-installed the software and updated it. I don't know if this will pertain to you or not.

AZ325Ci is offline  
#3 (permalink) Old 12-05-2005, 08:12 AM
1st Gear Member
 
bimmerboy328i's Avatar
 
Join Date: Apr 2004
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bimmerboy328i is an unknown quantity at this point
Send a message via AIM to bimmerboy328i
Have you checked all of your ground points? If the cam sensor was not working, you would have a CEL.

- 97 M52 Beast - Vortech V-1 Supercharger Setup - Dinan Software - 28.8lb Injectors - 9psi - ZKW's - OEM Clears - DoubleSpoke II's - OEM M3 Spoiler - OEM M3 Front Bumper - 20% Tint - CCFL Angel Eyes - 6K Xtec HIDs in ZKWs - 6k H1 based D2S HID's in Foglights - Bilstein Sport Shocks - Eibach Sportline Springs - Cosmos Racing CAI - M50 Manifold Swap - UUC Motorwerks SystemU Exhaust - Fan Delete - 3.15 LSD -
bimmerboy328i is offline  
#4 (permalink) Old 12-05-2005, 09:35 AM
1st Gear Member
 
Join Date: Sep 2005
Posts: 236
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hootie is on a distinguished road
Actually, the camshaft sensor problem won't necessarily leave a fault in the computer. I had it happen on my intake and the mechanic charged me $70 to tell me there was nothing IN the computer. Took another week of driving before it appeared in the computer again.

D4, have a mechanic check your fault codes. Or buy a reader and do it yourself. Either way, that will tell you if it's your camshaft sensor. If it is, it's about a 30 minute repair you can do yourself. FYI, my sensor went out at about 60K too, similar symptoms. How's your gas mileage and idling?
Hootie is offline  
#5 (permalink) Old 12-05-2005, 09:54 AM
n00b
 
Join Date: Dec 2005
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
D4LJE is on a distinguished road
(Thread Starter)
Used a programe

called carsoft, i erased the fault code and nothing come up, once the car stalled again ie while reduceing speed, i put on carsoft and it come up with cam shaft sensor, there are 2 sensors fitted, they are about £60pound each, i will get back to you guys once iv had them replaced.
D4LJE is offline  
#6 (permalink) Old 12-05-2005, 10:36 AM
1st Gear Member
 
bimmerboy328i's Avatar
 
Join Date: Apr 2004
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bimmerboy328i is an unknown quantity at this point
Send a message via AIM to bimmerboy328i
Quote:
Originally Posted by Hootie
Actually, the camshaft sensor problem won't necessarily leave a fault in the computer. I had it happen on my intake and the mechanic charged me $70 to tell me there was nothing IN the computer. Took another week of driving before it appeared in the computer again.

D4, have a mechanic check your fault codes. Or buy a reader and do it yourself. Either way, that will tell you if it's your camshaft sensor. If it is, it's about a 30 minute repair you can do yourself. FYI, my sensor went out at about 60K too, similar symptoms. How's your gas mileage and idling?
It will leave a fault in the computer no matter what. Except the computer has to see it twice too throw a CEL. So if it was a major problem, it would have already come up.

- 97 M52 Beast - Vortech V-1 Supercharger Setup - Dinan Software - 28.8lb Injectors - 9psi - ZKW's - OEM Clears - DoubleSpoke II's - OEM M3 Spoiler - OEM M3 Front Bumper - 20% Tint - CCFL Angel Eyes - 6K Xtec HIDs in ZKWs - 6k H1 based D2S HID's in Foglights - Bilstein Sport Shocks - Eibach Sportline Springs - Cosmos Racing CAI - M50 Manifold Swap - UUC Motorwerks SystemU Exhaust - Fan Delete - 3.15 LSD -
bimmerboy328i is offline  
#7 (permalink) Old 12-05-2005, 12:36 PM
1st Gear Member
 
storme's Avatar
 
Join Date: Jan 2005
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
storme is an unknown quantity at this point
had my camshaft sensor sorted at the weekend...took 5 minutes to change...idles great now....

if it goes kapputt..your car wont start

visit me at <a href='http://www.storme.co.uk' target='_blank'>www.storme.co.uk</a>

visit me at http://www.janspeed.com
storme is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
E46 Aerial help ? Ramon Di Carrera 3-Series (E46, E90) 3 11-12-2005 09:44 AM
WTB: M3 Style hood for an 04 BMW 330CI E46 4bidden Looking For 0 11-04-2005 12:40 PM
Help with E46 aerial connection ? Ramon Di Carrera Audio and Electronics 0 11-03-2005 12:02 PM
e46 330xi vs e46 325i Hot Sauce Driving Tales 3 10-26-2005 08:42 AM
2003 E46 330I OEM Hood thread OEM Parts 1 09-19-2005 07:07 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome