E46 318i (2002) Battery Light - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-06-2010, 07:37 AM   #1 (permalink)
Neutral Member
 
Join Date: Nov 2008
Car: E46 2002 318i F/L (104.4KWs)
Posts: 74
Photos:
sPoNgE-SA is on a distinguished road
E46 318i (2002) Battery Light

Hi all,

For the last week my battery light comes on Intermittently. My revs drop and complete loss of power for a second and then battery light comes on and then comes off right away. The battery was charging at 16Volts so I had the alternator replaced/ Charging is fine but the problem has come back, I have had my car tested. The guys I go to only work on BMW's, the head mechanic drove around with me so I could show him the problem but it failed to happen again.

Any thoughts?
sPoNgE-SA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-06-2010, 09:53 AM   #2 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
How about the voltage regulator?
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 04-06-2010, 01:57 PM   #3 (permalink)
Neutral Member
 
Join Date: Nov 2008
Car: E46 2002 318i F/L (104.4KWs)
Posts: 74
Photos:
sPoNgE-SA is on a distinguished road
Quote:
Originally Posted by witeshark View Post
How about the voltage regulator?
Is this not part of the Alternator? The voltage is fine now but the battery light still comes on complete loss of power for a second.
sPoNgE-SA is offline   Reply With Quote
Old 04-06-2010, 02:45 PM   #4 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Yeah the regulator is intregral on many. I'm thinking a weak or loose connection somewhere.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 04-07-2010, 04:23 AM   #5 (permalink)
Neutral Member
 
Join Date: Nov 2008
Car: E46 2002 318i F/L (104.4KWs)
Posts: 74
Photos:
sPoNgE-SA is on a distinguished road
I will have to take it back and they will need to have it checked. They replaced the Alternator with a refurbished one. With the same problem still happening would replacing it not of fixed it. Then it's probably something else which isn't part of the Alternator. Could the overcharging not of damaged to battery?
sPoNgE-SA is offline   Reply With Quote
Old 04-07-2010, 09:13 AM   #6 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Overcharging may have caused an issue.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 04-08-2010, 09:54 AM   #7 (permalink)
Neutral Member
 
Join Date: Nov 2008
Car: E46 2002 318i F/L (104.4KWs)
Posts: 74
Photos:
sPoNgE-SA is on a distinguished road
Hi Whiteshark, my car is at the mechanic for two days now. The damn problem doesn't happen when they test drive the car. I even took them for two long drives and nothing. They have checked everything and nothing. They keep telling me that they can't fix it without knowing the problem or seeing it. I even drove the car with Live Data testing and nothing. No error codes. This is very fustrating. Should I get a loan battery and test that ? Any advice please.
sPoNgE-SA is offline   Reply With Quote
Old 04-08-2010, 10:28 AM   #8 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Wow, I guess that's worth a try.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 04-13-2010, 03:33 AM   #9 (permalink)
Neutral Member
 
Join Date: Nov 2008
Car: E46 2002 318i F/L (104.4KWs)
Posts: 74
Photos:
sPoNgE-SA is on a distinguished road
Any idea what amps should be when the Alternator is charging or when there's load on the battery?
sPoNgE-SA is offline   Reply With Quote
Old 04-15-2010, 06:03 AM   #10 (permalink)
Neutral Member
 
Join Date: Nov 2008
Car: E46 2002 318i F/L (104.4KWs)
Posts: 74
Photos:
sPoNgE-SA is on a distinguished road
ok, so far so good. Car was fine today but too ealry to say.

What was done.
1. Replaced Alternator
**** problem still exists****
2. Replaced Igintion
**** problem still exists****
3. Replaced Alternator and Crank Shaft Sensor, assuming the Alternator was faulty

Car drove 1 day so far with no problems.

Will keep updated.
sPoNgE-SA is offline   Reply With Quote
Old 04-15-2010, 07:40 AM   #11 (permalink)
Neutral Member
 
Join Date: Nov 2008
Car: E46 2002 318i F/L (104.4KWs)
Posts: 74
Photos:
sPoNgE-SA is on a distinguished road
Youtube video of problem. Recorded a few days ago.

sPoNgE-SA is offline   Reply With Quote
Old 04-15-2010, 10:18 AM   #12 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Maybe the gage cluster needs a look. It looks like the oil pressure gage fluctuates a lot.
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 04-15-2010, 10:52 AM   #13 (permalink)
Neutral Member
 
Join Date: Nov 2008
Car: E46 2002 318i F/L (104.4KWs)
Posts: 74
Photos:
sPoNgE-SA is on a distinguished road
Hey Witeshark, that's the fuel consumpition gauge. Don't think it's a oil pressure gauge.
sPoNgE-SA is offline   Reply With Quote
Old 04-15-2010, 10:57 AM   #14 (permalink)
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Car: 89 E30 325i, 2007 Honda
Posts: 14,690
Photos:
witeshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nicewiteshark is just really nice
Okay, kinda hard to see... Good luck sorting it!
__________________
BMW

Sig by zeaq
witeshark is offline   Reply With Quote
Old 04-15-2010, 11:10 AM   #15 (permalink)
Neutral Member
 
Join Date: Nov 2008
Car: E46 2002 318i F/L (104.4KWs)
Posts: 74
Photos:
sPoNgE-SA is on a distinguished road
no probs, sorry about that crap video. Was taken with my mobile phone.
sPoNgE-SA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 528i dead battery problem please help!! mbaconusa 5-Series (E12,E28, E34, E39, E60) 7 03-14-2010 02:14 PM
2002 E46 318i - error codes P2776 and P278a HELP alex1974 3-Series (E46, E90) 3 11-19-2009 08:10 AM
E46 318i 2002 Clutch Problem sPoNgE-SA 3-Series (E46, E90) 0 02-25-2009 08:36 AM
The battery on my 2002 525i is missing... npnp 5-Series (E12,E28, E34, E39, E60) 4 11-17-2006 01:19 PM
95 318I battery fuse DropTopBeamer 3-Series (E36) 1 07-27-2003 07:50 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:27 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.