In desperate need of help! - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-05-2011, 12:41 PM   #1 (permalink)
n00b
 
Join Date: Aug 2009
Car:
Posts: 2
Photos:
jwmcdermid is on a distinguished road
In desperate need of help!

Hello people.

I seem to have a problem with my BMW 320d with it boosting.

OK, i have two 320Ds. One which was bought about 3 months ago with 57k miles on the clock. The other is the same but has done 208k miles. They are both on 2003 registered cars.

I managed to hit a badger in my older beemer and it decided to rip my intercooler and my splash tray to shreds, as the new one which was bought i knew wasn't going to be used for a little while, to save money i decided to 'borrow' the intercooler off my new one. Easy job, splash tray off a couple of torx screws and some pipes. I put the intercooler on the older car, no problem, car was boosting and is still running well as i type this.

I seem to have a problem with my new one, i bought a brand new intercooler for it and put it back on. Now i get no boost at all and a crazy amount of black smoke. I have taken the intercooler off several times to make sure that the pipes are in correctly and that it is not damaged in any way. I don't seem to see anything wrong with it. The car was boosting perfectly before this.

Could someone please help me on finding out why this has happened to a car that has only done 57k miles and all that was done to it was an intercooler taken off and new one put back on. I don't really wanna take this to a garage as i am quite confident to do things myself. My old beemer is still working perfectly and for the past 4 years i have done everything myself. I am just really stuck on figuring out why it is doing this....

Thanks

Jamie
jwmcdermid is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electric Fan Controller InstallI AM DESPERATE FOR HELP!!! GROUNDED!!! gadfly 3-Series (E36) 9 01-05-2010 04:02 PM
318TDS E36 stalling... I'm Desperate! PLZ HELP! itsuki_takeuchi 3-Series (E36) 3 12-10-2009 07:33 PM
I Need Help Im Desperate laceyann 3-Series (E21, E30) 2 11-26-2007 05:03 PM
Desperate Help Needed Please scoobytyper26 3-Series (E36) 6 01-24-2005 01:59 PM
In Desperate Need Of Help!! All wheels rolling 3-Series (E21, E30) 1 01-04-2005 01:33 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:52 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.