COLD start, oil LIGHT - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-13-2009, 06:49 PM   #1 (permalink)
n00b
 
Join Date: Nov 2009
Car:
Posts: 2
Photos:
bimmer freak is on a distinguished road
COLD start, oil LIGHT

hello all.

whenever i start the car in the morning or when its cold, the rpm acts like a heart beat detector, it goes down to 400 and gets back to normal and keeps doing that until it warms up, and sometimes it shuts off but i start it back again without any problems, what do you all think?

2nd thing i got an oil leak from the oil filter housing o-ring, i'll fix it soon but i need to know if that has any thing to do with the yellow light that comes on right after i start the car and goes off within 20 seconds?


forgot to mention its a 2000 328i
bimmer freak is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-13-2009, 06:52 PM   #2 (permalink)
Millions of them.
 
Torque's Avatar
 
Join Date: Dec 2003
Location: USA
Car: e36 w/ a m42
Posts: 14,878
Photos:
Torque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond reputeTorque has a reputation beyond repute
The idle sounds like a idle control valve (more commonly referred to as ICV); sounds like it could need a good cleaning.

As for the oil light ... 20 seconds seems an awful long time for it to go out. Are you absolutely positive you're not running low on oil? If the answer is no, I'm gonna go ahead and suspect that your oil is too thick for the temperatures and it's causing a low pressure condition on startup.
__________________
Torque is offline   Reply With Quote
Old 12-13-2009, 06:57 PM   #3 (permalink)
n00b
 
Join Date: Nov 2009
Car:
Posts: 2
Photos:
bimmer freak is on a distinguished road
Quote:
Originally Posted by Torque View Post
The idle sounds like a idle control valve (more commonly referred to as ICV); sounds like it could need a good cleaning.

As for the oil light ... 20 seconds seems an awful long time for it to go out. Are you absolutely positive you're not running low on oil? If the answer is no, I'm gonna go ahead and suspect that your oil is too thick for the temperatures and it's causing a low pressure condition on startup.
idle proplem: is it suppose to do that even when the car is completly warmd up cause it only does it when its cold + why does it shutt off, it pisses me off honestly!

oil: i always check the oil level before i drive the car, and fill it up with 5w/30 the one that last for 15,000 miles

Last edited by bimmer freak; 12-13-2009 at 07:04 PM.
bimmer freak is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
cold start beamerguy 5-Series (E12,E28, E34, E39, E60) 0 12-26-2008 06:24 PM
cold start? enemigo 3-Series (E36) 7 07-08-2006 12:06 PM
Beeping Noise On Every Start... Not Cold, Not Oil! zach 3-Series (E46, E90) 2 02-25-2005 02:15 PM
Cold Start? denn34 3-Series (E21, E30) 2 01-30-2005 01:48 PM
Cold start noise moto 3-Series (E46, E90) 1 10-01-2003 12:30 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:12 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.