Check Engine Light After Removing Gauge Cluster - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-23-2008, 08:14 PM   #1 (permalink)
n00b
 
acon's Avatar
 
Join Date: May 2004
Location: Miami, FL
Car: 2004 325i
Posts: 43
Photos:
acon is an unknown quantity at this point
Check Engine Light After Removing Gauge Cluster

Since I can't leave well enough alone, I've decided to put some M3 style gauge face on my '04 4dr E46. So I remove my gauge cluster last night, put the gauge face on and put in the cluster back this morning, only do find out that the check engine light and windshield washer light indicators are on.

I disconnected it and connected it again but they don't come off. Any suggestions? I've removed the cluster in the past but I guess since I left this out for a while something must of have triggered this. Thanks!
acon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-24-2008, 01:00 PM   #2 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
Try disconneting the Batt for 15 mins, NEG 1st then +, re-connect + 1st followed by NEG
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 10-26-2008, 02:51 PM   #3 (permalink)
n00b
 
acon's Avatar
 
Join Date: May 2004
Location: Miami, FL
Car: 2004 325i
Posts: 43
Photos:
acon is an unknown quantity at this point
Thanks, but no luck. Also forgot to mention that the board computer is not working either. I can see how much miles to the next service when I turn on the car, but I can't access the other functions (outside temp, mpg/mph average, etc) Maybe the bc needs to be reset or something.
acon is offline   Reply With Quote
Old 10-26-2008, 03:06 PM   #4 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
Ok, you need to get a diagnostic done to find what is wrong.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 10-29-2008, 07:42 AM   #5 (permalink)
n00b
 
acon's Avatar
 
Join Date: May 2004
Location: Miami, FL
Car: 2004 325i
Posts: 43
Photos:
acon is an unknown quantity at this point
Guess what marti5? The next day the service engine light came off and I can now access the board computer! Guess she needed some "alone time" after disconnecting/reconnecting the battery, ha ha. Hopefully it's this and not a matter of it coming back on & off. Thanks mate!!
acon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Diy: Gauge Cluster Light Delete ///M Power 5-Series (E12,E28, E34, E39, E60) 11 08-10-2005 09:23 AM
Removing Gauge Cluster exjarhead328 3-Series (E46, E90) 1 03-10-2005 02:22 PM
Gauge Cluster Light Burnt Out Silverstreak 3-Series (E36) 3 02-19-2005 12:23 AM
Check Engine Light & Air Bar Light blackstallion 3-Series (E36) 1 11-11-2004 11:53 AM
loud engine noise and check engine light steviebhoy 3-Series (E36) 4 06-04-2004 06:59 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:46 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.