Check engine light - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-29-2007, 01:33 PM
n00b
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
DCbmw2001 is on a distinguished road
(Thread Starter)
Check engine light

I recently purchased a 2001 BMW 325i with 66K miles. The car runs great and everything seems to be fine. However, I noticed that the check engine light came on couple of times before an oil change. However, after an oil change, the check engine light came on more frequently and a whining sound coming from oil-filter housing when the engine is turned on (i.e. when the engine is cold). But the noise goes away, whereas the check engine light is persistent.

My mechanic has so far changed the vacuum hose and the spark plugs. The code of the "check engine light" is usually states Bank 1 and Bank 2 problem. I also took it to BMW dealership and the tech there suggested changing the "oil separator". Being frustrated with this, I want to know whether it sounds ok to change the oil separator or is it another hoax?

I appreciate your input. Thanks!
DCbmw2001 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-29-2007, 06:15 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
what OIL filter did you use... also ho long does it make the sound?

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#3 (permalink) Old 11-29-2007, 06:42 PM
n00b
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
DCbmw2001 is on a distinguished road
(Thread Starter)
I'm not sure about the oil filter, but the oil change was done by BMW dealership, so I think they used a proper filter. The sounds is about 10 minutes after starting from cold engine and once the engine is warmed up, the sound disappears...
DCbmw2001 is offline  
#4 (permalink) Old 11-29-2007, 06:57 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
hmmm I was thinking that it is air in the oil filter housing or the improper Filter.........

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#5 (permalink) Old 11-29-2007, 09:55 PM
2nd Gear Member
 
zibby's Avatar
 
Join Date: Dec 2004
Location: Vancouver, Canada
Posts: 507
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
zibby is an unknown quantity at this point
Quote:
Originally Posted by DCbmw2001
I recently purchased a 2001 BMW 325i with 66K miles. The car runs great and everything seems to be fine. However, I noticed that the check engine light came on couple of times before an oil change. However, after an oil change, the check engine light came on more frequently and a whining sound coming from oil-filter housing when the engine is turned on (i.e. when the engine is cold). But the noise goes away, whereas the check engine light is persistent.

My mechanic has so far changed the vacuum hose and the spark plugs. The code of the "check engine light" is usually states Bank 1 and Bank 2 problem. I also took it to BMW dealership and the tech there suggested changing the "oil separator". Being frustrated with this, I want to know whether it sounds ok to change the oil separator or is it another hoax?

I appreciate your input. Thanks!
There is no "check the engine" code bank 1 or bank 2.Bank 1 or 2 of what! ?
Find exactly what code your car is throwing out and post again.
As an example this could be "camshaft position sensor" bank 1 or 2.
Bank itself means nothing...
zibby is offline  
#6 (permalink) Old 11-30-2007, 02:48 AM
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Posts: 1,052
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute
oil separator is common problem and if you have it at dealer then im sure theyre qualified. Its probably a code for bank 1 and 2 too lean

DT




Dirty_Tool is offline  
#7 (permalink) Old 12-05-2007, 08:36 PM
n00b
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
DCbmw2001 is on a distinguished road
(Thread Starter)
correct, it's bank 1 and 2, engine too lean...
DCbmw2001 is offline  
#8 (permalink) Old 12-05-2007, 08:38 PM
n00b
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
DCbmw2001 is on a distinguished road
(Thread Starter)
thanks for your inputs...I'm taking the car to the dealer tomorrow...
DCbmw2001 is offline  
#9 (permalink) Old 12-05-2007, 08:40 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
fuel delivery issue? clogged injector maybe? maybe run some seafoam in the gas when your low on gas...

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#10 (permalink) Old 12-08-2007, 01:13 PM
n00b
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
DCbmw2001 is on a distinguished road
(Thread Starter)
Just wanted to let you know that I had the "Oil Separator" replaced along with its vacuum hoses, and the car is back to normal with the "check engine" light off for the second day in a row...
DCbmw2001 is offline  
#11 (permalink) Old 12-08-2007, 06:31 PM
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Posts: 5,992
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold AlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
thats good!

1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline  
#12 (permalink) Old 12-10-2007, 04:09 AM
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Posts: 1,052
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute Dirty_Tool has a reputation beyond repute
hehe ... told ya :-)

DT




Dirty_Tool is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
97" 540IA mystery with the check engine light ClaytonP 5-Series (E12,E28, E34, E39, E60) 3 10-21-2007 09:43 PM
Check Engine Light On, But Only When I Start Car BMW-ATI 3-Series (E36) 5 04-15-2005 10:40 PM
Inspection I iantosca 3-Series (E36) 5 09-18-2004 01:18 AM
Check Engine light went away Ferrahs 3-Series (E36) 14 07-17-2004 03:32 PM
service questions thamindzzeye 3-Series (E36) 4 04-30-2003 03:40 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome