ABS, brake, and ASC warning lights on!? - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-20-2004, 10:12 AM
n00b
 
Join Date: May 2004
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mantoboy is an unknown quantity at this point
(Thread Starter)
I have a '99 328i. Wondering if any of you have experienced problems with the warning lights (ABS, brake, and ASC) warning lights all coming on at the same time, after ignition?

It doesn't always do that. Sometimes, it would come on, and then turn off after a few miles of driving. Sometimes, it would stay on for 30 miles or longer.

There isn't really that much to explain other than that. I've never had other problems with the braking system before. I'm guessing this is just some problems with the wiring or sensors again? I have similar problems with the front right headlight, but this is a smaller problem compared to not having ABS.

ghead
mantoboy is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-26-2004, 10:29 AM
n00b
 
Join Date: Jun 2004
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
boaz is an unknown quantity at this point
Hi
I have the same problam in 328I 1999 BMW told me its the hidraulic unit but like you, i think its some kind of senssor becuase its on/off.someone in the forum sayed it happend becuase he was parking and the parking were tilting left,he changed parking spot the problam gone. so maybe its something with the oil pressure inside the hidraulic unit. Im trying to get info about this unit and how to add/change oil inside it when ill find something ill tet you know please inform me of any info you found. there 3 of us with the same problam lets do somthing about it. alonitr@hotmail.com
boaz is offline  
#3 (permalink) Old 06-27-2004, 05:00 PM
n00b
 
Join Date: May 2004
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mantoboy is an unknown quantity at this point
(Thread Starter)
Boaz,

I don't have much knowledge about the hydraulics unit. BTW, did u have any accidents before? I had an accident earlier where I crashed the front of the car (just structural damage) but I'm guessing there may be wires that are not fixed properly. Do you know where the hydraulics unit is located exactly? Maybe that unit is faulty but it was missed by the repair shop.
mantoboy is offline  
#4 (permalink) Old 06-27-2004, 05:13 PM
1st Gear Member
 
Join Date: May 2004
Location: Seattle, WA
Posts: 262
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
KillFox is an unknown quantity at this point
Send a message via AIM to KillFox Send a message via Yahoo to KillFox
There is some sort of hydrolic unit, at least it looks like one, just behind the front bumper on the passenger side. To get to it, you just have to unscrew about 3 screws in the front splash guard located in your wheel well, then take it off. You can then see what i am talking about just on the left of the wheel well.

I borrowed a pic from e46 fanatics. Again, i dont know if it really is what u are after or not.
Attached Thumbnails
Click image for larger version

Name:	tempsensorlocation.jpg
Views:	7377
Size:	161.6 KB
ID:	9561  

<img src='http://3dwire.net/~matt/killfoxsig2.gif' border='0' alt='user posted image' />
KillFox is offline  
#5 (permalink) Old 06-27-2004, 05:41 PM
Been here a while.
 
97alpineM3's Avatar
 
Join Date: May 2004
Location: Virginia
Posts: 5,375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all
Send a message via AIM to 97alpineM3 Send a message via MSN to 97alpineM3
Have you taken it to a dealer???.... they could probably tell you its a sensor.. or not....


1997 E36 M3 1990 E30 325i
97alpineM3 is offline  
#6 (permalink) Old 12-23-2008, 02:59 AM
n00b
 
Join Date: Dec 2008
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bmwfan12 is on a distinguished road
hey i have 97 bmw 528i i have a problem in my traction and abs light is on as soon as the lights came on my car runs on force could any 1 help me on this please
bmwfan12 is offline  
#7 (permalink) Old 12-23-2008, 09:12 AM
n00b
 
Join Date: Dec 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
j40ko is on a distinguished road
Quote:
Originally Posted by bmwfan12 View Post
hey i have 97 bmw 528i i have a problem in my traction and abs light is on as soon as the lights came on my car runs on force could any 1 help me on this please
i also have this problem on my 328 1999 model
j40ko is offline  
#8 (permalink) Old 12-23-2008, 09:18 AM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,697
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
A brake fluid change may help.

BMW

Sig by zeaq
witeshark is offline  
#9 (permalink) Old 02-04-2009, 02:49 AM
n00b
 
Join Date: Feb 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Gorv330d is on a distinguished road
Has anyone found a solution to this problem? I have a 2000 330d and just turned my ignition on today to find all 3 of the mentioned lights on.
Interesting though, is that I have the same problem with my front right headlight. It works for 2-4 weeks then needs replaced. If anyone has solved the mystery please let me know.
Gorv330d is offline  
#10 (permalink) Old 02-09-2009, 06:54 PM
n00b
 
sonspot's Avatar
 
Join Date: Oct 2008
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sonspot is on a distinguished road
get your car scanned, all this guess work is going no where, if your lucky its just a dirty or bad speed sensor, getting the car scanned will tell which one is faulty.

BTW when those lights are on you dont have ABS,..

2001 330I, sport/Premium/cold weather package, short shifter with M3 weighted knob, clear corners, 60 led angle eyes

Last edited by sonspot; 02-09-2009 at 06:58 PM.
sonspot is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome