330D Not starting when hot??? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-28-2009, 12:48 PM   #1 (permalink)
n00b
 
Join Date: Nov 2009
Car:
Posts: 3
Photos:
bmwjoburg is on a distinguished road
Unhappy 330D Not starting when hot???


Hi there. My 2004 330d is not starting when hot.
I took it to a Bosch service centre and they told me that 5 of the injectors need replacing. Is it possible for 5 injectors to fail at once. The fault started without warning, not a case where it gets worse with time. The car starts immediately when pushed. Fuel consumption is normal, power seems normal. It starts in the mornings when the engine has cooled down after turning the key for about two or three seconds. I replaced the battery after the fault started, cleaned out the air filter( this seemed to help a bit?) and added a diesel additive that cleans valves and injectors. The problem still persists and I do not want to replace the injectors without some other oppinions.
I did not get any error codes or printouts from the service guy's. I was told that they had a printer error, That is why I dont trust them with their diagnoses.
Ps: I was quoted more about two thirds of the car's trade in value for new injectors. Is this a job that can be done at home?
bmwjoburg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-28-2009, 12:55 PM   #2 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
If it starts when pushed then your injectors are fine, I would say its your HP pump, for 5 to go at once nah dont think so, you say no codes? so its not electrical then.... HP pump, but do wait for other members opinions.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 11-28-2009, 03:13 PM   #3 (permalink)
n00b
 
Join Date: Nov 2009
Car:
Posts: 3
Photos:
bmwjoburg is on a distinguished road
Smile

Thanx for the reply.
What about the fact that fuel consumption and power seems normal?
bmwjoburg is offline   Reply With Quote
Old 11-29-2009, 11:32 AM   #4 (permalink)
n00b
 
TMC Motorsport's Avatar
 
Join Date: Nov 2009
Location: Ireland
Car: 2007 330d Convertible
Posts: 11
Photos:
TMC Motorsport is on a distinguished road
Send a message via MSN to TMC Motorsport
Quote:
Originally Posted by bmwjoburg View Post
Thanx for the reply.
What about the fact that fuel consumption and power seems normal?
I would agree, highly unlikely that 5 injectors would go at once and if they did it wouldn't run normally after a push. Sounds like maybe a fuel leak around the common rail or air getting into the fuel system or a leak in the air intake. Check out all the little vacuum pipes around the engine, also check the larger air intake hoses for any splits. Have you changed the fuel filter and are there any funny noises from the fuel pump? Any fuel leaks visible? A fault code reader should show something.

I'm pretty sure changing five injectors won't cure it.
TMC Motorsport is offline   Reply With Quote
Old 11-29-2009, 12:41 PM   #5 (permalink)
n00b
 
Join Date: Nov 2009
Car:
Posts: 3
Photos:
bmwjoburg is on a distinguished road
Thanks. I will have a look in the morning. I did not see any leeks below the car on the ground or any diesel smells. I will change the diesel filter and check the air hoses. What is the function of the cam sensor. Somebody on another forum had a simmilar problem, and it was recomended that he check out the cam sensor?
bmwjoburg is offline   Reply With Quote
Old 11-29-2009, 12:53 PM   #6 (permalink)
n00b
 
TMC Motorsport's Avatar
 
Join Date: Nov 2009
Location: Ireland
Car: 2007 330d Convertible
Posts: 11
Photos:
TMC Motorsport is on a distinguished road
Send a message via MSN to TMC Motorsport
Quote:
Originally Posted by bmwjoburg View Post
Thanks. I will have a look in the morning. I did not see any leeks below the car on the ground or any diesel smells. I will change the diesel filter and check the air hoses. What is the function of the cam sensor. Somebody on another forum had a simmilar problem, and it was recomended that he check out the cam sensor?
It just picks up the rotations of the camshaft, its possible but that would surely show up on an OBD check. Do you have anyone nearby with an OBD fault code reader? If not you can buy them off Ebay now pretty cheap (less than 100$) just make sure if you buy one it def supports your model.
They are a really good tool to have for modern cars, they don't solve every problem but can usually point you in the right direction.
BTW you can get injectors re-conditioned even if they are faulty so no need to buy new ones. I can give you numbers of UK companies who can re-con them as new. But again I don't think thats your problem, injectors are just magnetic solenoids opening and closing, if they were faulty they just wouldn't work at all even with a push start.
TMC Motorsport is offline   Reply With Quote
Old 11-29-2009, 01:06 PM   #7 (permalink)
n00b
 
TMC Motorsport's Avatar
 
Join Date: Nov 2009
Location: Ireland
Car: 2007 330d Convertible
Posts: 11
Photos:
TMC Motorsport is on a distinguished road
Send a message via MSN to TMC Motorsport
Just spoke with my buddy who is a head Landrover Technician, they use this engine in Range Rovers too, he says 100% its the camshaft sensor!! Replace it and problem solved. He says that is the only thing that will cause not starting when warm.

Problem solved. Good luck let me know if it works out. Cheers
TMC Motorsport is offline   Reply With Quote
Old 11-30-2009, 06:12 AM   #8 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
Ah, Thats good to know for future reference, Cheers.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 330d - Groggy starting issue joshgeake 3-Series (E46, E90) 1 02-02-2009 08:24 AM
E34 525tds Auto Hot Starting & Stalling peterbrent 5-Series (E12,E28, E34, E39, E60) 8 09-21-2008 07:48 AM
330d red330Iperfpkg Bimmer Talk/Motorsports Talk 8 12-05-2006 12:12 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:08 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.