1999 323i need help with poor acceleration - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-12-2008, 10:25 AM
n00b
 
Join Date: Nov 2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bkpiper00 is on a distinguished road
(Thread Starter)
1999 323i need help with poor acceleration

Hi, I am new to this forum. I have a 1999 323i with 140K that runs fine as long as you dont try and get on it. If you keep it below 3500 rpms it runs great and the idle is perfect at 750-800. I will say that even with it driving fine under those conditions I still get the P0420 & P0430 OBDII codes.

Now comes the problem. When I try to get on the car it starts to studder and olmost dies and the idle is very erratic. I then get misfire codes P0301,P0304,P0305 & P0306. This from what I understand means misfires in cylinders #1,3,4,5 &6. I have replaced coil #1 and all new NGK plugs and plug connectors from BMW, not aftermarket. the problem still exist.

Can a bad o2 sensor cause this? How about the codes reading catalytic threshold to low (P0420 & P0430)? if its the Cat could this cause the misfire?

Any help Please

Bryan
bkpiper00 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-12-2008, 02:47 PM
n00b
 
Join Date: May 2007
Location: OC
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
GRIDLOCK is on a distinguished road
Your issue sounds more like a vacuum leak somewheres. A smoke-test is in order.
GRIDLOCK is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Groan on Initial Acceleration '99 BMW 323i dkatrencik 3-Series (E46, E90) 2 11-11-2005 04:53 PM
Poor Acceleration With 540i ericmalkoc 5-Series (E12,E28, E34, E39, E60) 6 07-06-2005 06:18 PM
1995 E34 540i Poor Acceleration Cambridge 5-Series (E12,E28, E34, E39, E60) 1 03-29-2005 01:16 PM
'92 525iT poor acceleration wilkie3 5-Series (E12,E28, E34, E39, E60) 8 08-03-2004 10:38 PM
New M3 wheels on a 323i 1999 ateba 3-Series (E46, E90) 1 10-09-2003 10:07 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome