'00 320d - turbo failure ? emergency program ? WHAT ? - BMW Forum - BimmerWerkz.com
3-Series (E46, E90) Chat relating to the BMW 3-Series from 1999 to Current. Models include: BMW 316i, BMW 318i, BMW 318Ci, BMW 320i, BMW 323i, BMW 325i, BMW 330i, BMW 328 Ci, BMW 328i, BMW 325i/xi, BMW 330Ci, BMW 320d, BMW 330d, BMW 335d.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-17-2006, 02:10 AM
n00b
 
Join Date: Feb 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Nick.se is on a distinguished road
(Thread Starter)
Question '00 320d - turbo failure ? emergency program ? WHAT ?

Hey guys,

I just purchased a 2000 BMW 320d (136hp) and ive noticed that when i accelerate just when the turbo kicks in, it "turns off" again after 0.4 secs, and ive got not check engine lights or anything.

Do you have any idea what the problem could be ? used:

It has driven 165000 km but is in good condition.

Thanks in advance.

Nick
Nick.se is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-17-2006, 09:19 AM
1st Gear Member
 
bimmerboy328i's Avatar
 
Join Date: Apr 2004
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bimmerboy328i is an unknown quantity at this point
Send a message via AIM to bimmerboy328i
Have you checked for vacumm leaks? Is all of your piping from the turbo to the throttle body nice and tight?

- 97 M52 Beast - Vortech V-1 Supercharger Setup - Dinan Software - 28.8lb Injectors - 9psi - ZKW's - OEM Clears - DoubleSpoke II's - OEM M3 Spoiler - OEM M3 Front Bumper - 20% Tint - CCFL Angel Eyes - 6K Xtec HIDs in ZKWs - 6k H1 based D2S HID's in Foglights - Bilstein Sport Shocks - Eibach Sportline Springs - Cosmos Racing CAI - M50 Manifold Swap - UUC Motorwerks SystemU Exhaust - Fan Delete - 3.15 LSD -
bimmerboy328i is offline  
#3 (permalink) Old 02-18-2006, 01:25 AM
n00b
 
Join Date: Feb 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Nick.se is on a distinguished road
(Thread Starter)
im not a mechanic, but i had a friend of mine look at it, and he said that nothing seemed out of place or anything...

Is it possible that the previos owner has driven the car so gently, that is has adjusted to his/her driving and just needs to be driven hard ? It could just be me, but i think its getting more responsive every time i drive it... either that or im just loosing my mind

Im having a mechanic friend of mine looking at it on tuesday... and putting a tester on it..... hopefully its nothing serious, that car seems in really good condition all way round... im really happy about my purchase... although i had to sell my S500

Thanks for the help so far Bimmerboy
Nick.se is offline  
#4 (permalink) Old 02-19-2006, 09:53 AM
3rd Gear Member
 
Join Date: Aug 2003
Location: Baltimore MD
Posts: 729
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
peterkulesza is an unknown quantity at this point
describe this better. why do you say it "turns off" ??? do you have a sudden loss of power, if so at what revs? do you hear a whistle (waste gate stuck or malfunctioning? describe what happens.

some south african made motors had problems. whare was the car made?
peterkulesza is offline  
#5 (permalink) Old 02-19-2006, 02:04 PM
n00b
 
Join Date: Feb 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Nick.se is on a distinguished road
(Thread Starter)
It just looses the boost from the turbo, its just like if you switch the turbo off entirely, looses the boost it just had... (it kicks in at around 2000 rpm and turns off at 2300 or something like that) and the effect of the turbocharger just dissapears completely.... and the engine alone does "all" the acceleration.

I have no idea where its build. how do i check that ?

I can hear the turbo when i rev the motor in neutral etc. havent tried to listen when i drive...

But as i said before, no error messages or anything.

Appreaciate any help i can get.

//Nick
Nick.se is offline  
#6 (permalink) Old 02-19-2006, 02:14 PM
3rd Gear Member
 
Join Date: Aug 2003
Location: Baltimore MD
Posts: 729
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
peterkulesza is an unknown quantity at this point
this does sound like a faulty waste gate (valve opens too soon). any black smoke from exhaust? i do not knwo whether this triggers codes, certainly it does not have to trigger check engine light.

vin number, and a call to bmw will let you see where the motor was made. others on this forum may comment, cos i am NOT well versed in gettign the specs out of databases.
peterkulesza is offline  
#7 (permalink) Old 02-19-2006, 10:45 PM
n00b
 
Join Date: Feb 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Nick.se is on a distinguished road
(Thread Starter)
Thanks alot Peter, ill look into it !

Have a nice day.

Nick
Nick.se is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E46, E90)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!! 530d Turbo Failure or Not??? hyeung 5-Series (E12,E28, E34, E39, E60) 12 11-11-2006 07:15 PM
turbo problem with 320d Campbell 3-Series (E46, E90) 1 08-24-2003 04:25 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome