What went wrong with my o2 sensor? - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-07-2006, 03:34 AM   #1 (permalink)
n00b
 
Join Date: Mar 2006
Car:
Posts: 2
Photos:
smarandi86 is on a distinguished road
Unhappy What went wrong with my o2 sensor?

Hi everyone. I recently just got my head cover valve (gasget) changed along with my crankshaft seal. I have a 95 325i with 127k on it. When i picked it up from the mechanics and started the car, i noticed a kinda white smog coming out the back of my exugst. that does happen when the weather is cold out, but i've never seen it white like that. Anyways, the next day my check engine light came on. i took it back and we figured my 02 sensor went bad. could this have been something they did wrong, or is it typical for an 02 sensor to go bad after awhile? It cost me about $230 to get it fixed. it only took 40 mins. Also to add to my problems, my car had recently started to shake (rumble) when starting the car cold. It will do that for about 15 secs, then smooths out. Could it be my cold start valve? sometimes i'll turn the ignition and it will stall in starting (sounds like its clogged). the car doesn't fire up right way. i have to hold the ignition. Should i just sell this car while its still working?
smarandi86 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-07-2006, 04:54 PM   #2 (permalink)
3rd Gear Member
 
WarNox's Avatar
 
Join Date: Aug 2004
Location: Auckland, New Zealand
Car:
Posts: 780
Photos:
WarNox is an unknown quantity at this point
For the shaking and not starting it could be that your ICV is dirty and spark plugs could be old! check that out first!
__________________
<img src='http://www.geocities.com/thereisnothinglikeabmw/mycar1.jpg' border='0' alt='user posted image' />
WarNox is offline   Reply With Quote
Old 03-07-2006, 07:29 PM   #3 (permalink)
I am Teh Edumacator.
 
Teh Prof's Avatar
 
Join Date: May 2005
Location: ATL, London, and Barcelona
Car: 1999 Dinan 540i/6, 1995 Dinan 749
Posts: 4,520
Photos:
Teh Prof has much to be proud ofTeh Prof has much to be proud ofTeh Prof has much to be proud ofTeh Prof has much to be proud ofTeh Prof has much to be proud ofTeh Prof has much to be proud ofTeh Prof has much to be proud ofTeh Prof has much to be proud ofTeh Prof has much to be proud ofTeh Prof has much to be proud of
Send a message via AIM to Teh Prof
O2 sensors go out with some regularity on our cars.
__________________


1999 E39 540i/6-VF Stage 1 S/C, Dinan exhaust, Dinan strut+shock braces, Dinan ltwt flywheel + clutch, Dinan Brembo BBK, Dinan monoball, H&R Springs, Koni Yellows, M5 sways, Dinan forged 18" wheels, &c.

1995 E38 740i. Highly modded. Faster than you.

Sold 2-28-07: 1997 E36 M3/4, 8-30-05 RIP 1997 528i


Lindsay fan club member.
Teh Prof is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light came on today camnipotent 3-Series (E36) 22 05-17-2004 06:23 PM
New Car - Few Problems, Any Help Appreciated. Sagan 3-Series (E36) 8 05-16-2004 09:28 PM
O2 sensor rawcar2long 3-Series (E36) 2 01-22-2004 10:56 AM
ABS sensor light fault.. Ski Bimmer Talk/Motorsports Talk 6 04-18-2003 08:38 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:45 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.