Weird behavior from the PS system... - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

» Auto Insurance

» Featured Product
» Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-15-2004, 12:39 PM   #1 (permalink)
3rd Gear Member
 
kestrel325is's Avatar
 
Join Date: Jun 2004
Location: Henderson, NV
Car: 1995 325is 5-speed
Posts: 609
Photos:
kestrel325is is an unknown quantity at this point
So, I've looked at everything I can think of, and nothing came up on search.

Here's the deal: If I brake hard, and turn the car, the PS system groans and moans, even after the turn... It continues until I shut off the car. I checked the fluid level, and it's fine. I've bled the system, to no avail... Any suggestions?
kestrel325is is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-15-2004, 02:19 PM   #2 (permalink)
You Can Has A Custom Title!!
 
Kevin325i's Avatar
 
Join Date: Mar 2004
Location: Madison, WI
Car:
Posts: 2,613
Photos:
Kevin325i is an unknown quantity at this point
Send a message via AIM to Kevin325i
Does the steering feel unussually heavy to turn? Or is it binding anywhere when you turn the wheel? It could be a bad ps pump, or steering rack.
__________________
Kevin (President TBEA)

"WAAAAAAARRRRRIORS, come out to plaaaaay."
Kevin325i is offline   Reply With Quote
Old 07-15-2004, 02:34 PM   #3 (permalink)
3rd Gear Member
 
kestrel325is's Avatar
 
Join Date: Jun 2004
Location: Henderson, NV
Car: 1995 325is 5-speed
Posts: 609
Photos:
kestrel325is is an unknown quantity at this point
Not that I've noticed... I was thinking that the pump might be going bad (sounds like it), but I've not noticed any effect on the steering.
kestrel325is is offline   Reply With Quote
Old 07-15-2004, 02:37 PM   #4 (permalink)
You Can Has A Custom Title!!
 
Kevin325i's Avatar
 
Join Date: Mar 2004
Location: Madison, WI
Car:
Posts: 2,613
Photos:
Kevin325i is an unknown quantity at this point
Send a message via AIM to Kevin325i
It's probably just starting to go bad, or the whine is coming from something else that just needs to be lubed. It's the steering whine when you turn right, and not just a whine from the belts?
__________________
Kevin (President TBEA)

"WAAAAAAARRRRRIORS, come out to plaaaaay."
Kevin325i is offline   Reply With Quote
Old 07-15-2004, 03:17 PM   #5 (permalink)
3rd Gear Member
 
kestrel325is's Avatar
 
Join Date: Jun 2004
Location: Henderson, NV
Car: 1995 325is 5-speed
Posts: 609
Photos:
kestrel325is is an unknown quantity at this point
Right. I replaced the belts last week because I though that might be the culprit. (that, and they were completely shot.)

It makes the same whine that a PS pump makes when there's air in it. (thus, why I bled it.)

So, I'll start pricing out a PS pump.....

eek
kestrel325is is offline   Reply With Quote
Old 07-15-2004, 03:18 PM   #6 (permalink)
You Can Has A Custom Title!!
 
Kevin325i's Avatar
 
Join Date: Mar 2004
Location: Madison, WI
Car:
Posts: 2,613
Photos:
Kevin325i is an unknown quantity at this point
Send a message via AIM to Kevin325i
It sounds like it's getting old, you could probably wait awhile before it'll go bad on you. If you find a good deal on one and have some cash sitting around for it i'd say go for it.
__________________
Kevin (President TBEA)

"WAAAAAAARRRRRIORS, come out to plaaaaay."
Kevin325i is offline   Reply With Quote
Old 07-15-2004, 03:22 PM   #7 (permalink)
3rd Gear Member
 
kestrel325is's Avatar
 
Join Date: Jun 2004
Location: Henderson, NV
Car: 1995 325is 5-speed
Posts: 609
Photos:
kestrel325is is an unknown quantity at this point
thanks for the quick replies, btw.

kestrel325is is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Synthetic Oil and filter CiscoKid 3-Series (E36) 47 04-14-2014 06:00 PM
The American Vs. The German billB 5-Series (E12,E28, E34, E39, E60) 83 10-14-2004 07:09 PM
weird sound system static isosceles 5-Series (E12,E28, E34, E39, E60) 2 07-12-2004 01:02 PM
New technology coming to 2005 Infiniti models AZ325Ci Other Rides 4 06-13-2004 09:14 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:34 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.