Transmission Light And Odometer - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-24-2005, 09:33 PM
n00b
 
Join Date: Mar 2005
Location: Atl
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bmwultdrivinmach is an unknown quantity at this point
Send a message via AIM to bmwultdrivinmach Send a message via MSN to bmwultdrivinmach
(Thread Starter)
I was just wondering how often everyone's transmission (!) light comes on? For some reason my light comes on often when I am in sport mode or rev the engine to 5000 or higher. I don't to this often and it always goes of after I pull over and turn the engine off and then back on again. Another question is that my odometer and tank milage light have gone out. I can still slightly see them but they are not illuminated. Is there a single fuse or bulb for this?

100,000 mls+
bmwultdrivinmach is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-25-2005, 10:42 AM
pcy
Neutral Member
 
Join Date: Oct 2004
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pcy is an unknown quantity at this point
Quote:
Originally posted by bmwultdrivinmach@May 24 2005, 08:33 PM
I was just wondering how often everyone's transmission (!) light comes on? For some reason my light comes on often when I am in sport mode or rev the engine to 5000 or higher. I don't to this often and it always goes of after I pull over and turn the engine off and then back on again. Another question is that my odometer and tank milage light have gone out. I can still slightly see them but they are not illuminated. Is there a single fuse or bulb for this?
[snapback]347598[/snapback]
Automatic transmission or manual ?
Has the transmission fluid been changed ? Is the transmission fluid at the correct level?
If the fluid has been changed and the fluid is at the correct level, TCM (Transmission Control Module) may have gone bad. This is just a guess.

There are small bulbs behind the cluster that illuminate odometer and the other things. Buy few bulbs at the dealer ($2 a piece, I think), open the cluster, replace the bulbs.

pcy
pcy is offline  
#3 (permalink) Old 05-26-2005, 09:19 AM
Threadkiller
 
bitcore's Avatar
 
Join Date: Jan 2004
Location: High Point, NC
Posts: 2,907
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bitcore will become famous soon enough bitcore will become famous soon enough
bavauto sells the bubls for like 50 cents a piece.
Gauge cluster is an *ABSOLUTE BITCH* to remove, you need to remove the steering wheel to really get to all of the bulbs. You'll just wind up marring up the leather all around it wiggling it back and fourth.
Unless your steering wheel telescopes/tilts, I'd put this job off as long as possible :P


bitcore is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New owner of 1995 740i needs repair advice cafedj 1,6,7,8 - Series and Mini Cooper 32 10-04-2008 08:35 PM
Odometer Reset Required? cpirovano 3-Series (E36) 5 11-19-2004 03:30 PM
odometer light fade out after a while nizar 5-Series (E12,E28, E34, E39, E60) 0 06-29-2004 09:35 AM
Odometer Light stopped working kjlbryan 3-Series (E36) 3 05-28-2004 07:12 PM
Odometer Lights Anthonymharwood 3-Series (E36) 2 05-28-2004 09:43 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome