Transmission control unit - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-19-2009, 01:25 PM
n00b
 
Join Date: Jun 2008
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jayturk99 is on a distinguished road
(Thread Starter)
Transmission control unit

I recently had my tranny serviced and it stopped the warning light from coming on and going into limp mode. I had the codes read and I don't recall what they were, but no tranny codes. One was a speed sensor code and mechanic told me that could be causing light. But has I read more could it be the TCU? Where is this unit on a 93 325is? What does it look like? Is it clearly visible, or do I have to remove items to get to it. I was going to try and clean the contacts if possible.
jayturk99 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-20-2009, 03:53 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
You havent actually said what the problem is ?

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#3 (permalink) Old 10-20-2009, 06:31 AM
n00b
 
Join Date: Jun 2008
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jayturk99 is on a distinguished road
(Thread Starter)
I have been getting intermittent warning light for the transmission. The rotary looking light with the exclamation point. Car drives fine w/o light, no slippage. Light comes on car bogs down into 3rd, and I have to turn off wait a few secs. then start again light goes out. I disconnected the battery over night to clear it, ran for a few days now the prob. is back. Had tranny serviced, ran for a few days now prob. is back. THinking the TCU contacts may need cleaning.
jayturk99 is offline  
#4 (permalink) Old 10-20-2009, 06:56 AM
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Posts: 3,242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
marti5 is on a distinguished road
You could try locating it...behind the battery or in the engine comparment rear right hand side I think.

Are you sure there's enough fluid in the tranny ?? as low fluid level will cause this.

VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline  
#5 (permalink) Old 10-20-2009, 12:09 PM
n00b
 
Join Date: Jun 2008
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jayturk99 is on a distinguished road
(Thread Starter)
When the tranny was serviced, the ATF was put in car lowered, shifted through gears, raise more ATF put in and this was repeatedly done until it could take no more.
jayturk99 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Central locking control unit nelzabob 3-Series (E36) 1 06-16-2008 05:22 AM
Fs Bmw X5 Hydro Unit Dsc/control Unit/fastening BMWluke Audio/Miscellaneous Auto Parts 0 10-04-2007 10:21 PM
Climate Control Unit mmclaren 3-Series (E36) 2 06-20-2005 07:33 AM
Dsc Control Unit oscaroc 3-Series (E46, E90) 6 02-17-2005 08:47 PM
Fixed my climate control unit! mech9T8 3-Series (E36) 1 07-03-2004 02:36 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome