Strange idle problem, need advice... - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

» Auto Insurance

» Featured Product
» Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-01-2009, 12:12 AM   #1 (permalink)
n00b
 
Join Date: Sep 2009
Car:
Posts: 1
Photos:
mphilly77 is on a distinguished road
Strange idle problem, need advice...

I have a '96 328is and maybe about a month ago it started running really rough whenever i started it. When I first start the car the rpm's fluctuate a little and then levels out at about 700rpm but car still shakes and seems to idle rough even though the rpm's don't change. Once i take it out on the road and get to stop lights or have to stop my car anywhere the problem is gone. My dad said it probably just needs some new spark plugs but I just wanted to see if anyone else had any advice because it is annoying me. Thanks
mphilly77 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-01-2009, 12:29 AM   #2 (permalink)
Ich bin der Modifikator
 
johnnyBgood's Avatar
 
Join Date: Sep 2007
Location: Bayonne, NJ
Car: 97'E36 2.8 w/Optional Sport Package
Posts: 3,325
Photos:
johnnyBgood is a jewel in the roughjohnnyBgood is a jewel in the roughjohnnyBgood is a jewel in the rough
Garage
Welcome to the Werkz....... could be a dirty Mass Flow Sensor {MAF} or the idle control valve.......

Quick test on the MAF is to disconnect it and see if there is any change, if not then the MAF Sensor is the problem.....you could try cleaning it.....check out links below:

e36-tech.com | View topic - DIY: Cleaning your Mass Air Flow Sensor

http://www.bimmerwerkz.com/forum/3-s...ing-48667.html

jb
__________________
______________________________________
_______________________97 E36|Conforti Software|M50 Manifold|AFE|Borla|H&R| Bilstein |Eibach|Rockford|3.15 LSD
____________________________________________http://www.cardomain.com/ride/3129109
johnnyBgood is offline   Reply With Quote
Old 10-01-2009, 08:35 AM   #3 (permalink)
2nd Gear Member
 
Join Date: Jul 2008
Car:
Posts: 374
Photos:
FCPGroton is on a distinguished road
I would give the MAF and IAC a good cleaning and replace your spark plugs. See how she runs from there.
__________________
FCP Groton
877-634-0063 | info@fcpgroton.com

FCP Euro - European Car Parts Specialists
FCP Import - Import Replacement Car Parts
FCPGroton is offline   Reply With Quote
Old 10-01-2009, 10:45 AM   #4 (permalink)
Help from over the pond
 
marti5's Avatar
 
Join Date: Sep 2008
Location: IPSWICH. U.K.
Car: E38 1997 728i Individual
Posts: 3,242
Photos:
marti5 is on a distinguished road
If a clean doesnt cure it I would go for new MAF and dont buy a cheapy one, buy a Bosch.
__________________
VELVET BLUE UK INDIVIDUAL , IM THE LAST
UNITED WE STAND DIVIDED WE FALL

I stepped in a plate of Pasta the other day - now I have to worry about my Carbonara footprint!
marti5 is offline   Reply With Quote
Old 10-01-2009, 02:45 PM   #5 (permalink)
n00b
 
Join Date: Jan 2009
Location: CA
Car: 93 BMW 325I
Posts: 24
Photos:
Chivas1 is on a distinguished road
Quote:
Originally Posted by johnnybayonne View Post
Welcome to the Werkz....... could be a dirty Mass Flow Sensor {MAF} or the idle control valve.......

Quick test on the MAF is to disconnect it and see if there is any change, if not then the MAF Sensor is the problem.....you could try cleaning it.....check out links below:

e36-tech.com | View topic - DIY: Cleaning your Mass Air Flow Sensor

http://www.bimmerwerkz.com/forum/3-s...ing-48667.html

jb
How long do you disconnect the MAF for? is it the same as testing the ICV? when you disconnect there should be a difference in engine sound right?

Thanks in advance
Chivas1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange random vibration at idle zabak80 3-Series (E36) 5 05-24-2009 03:19 PM
Strange Idle/Spark plugs/BMW speaker e30dream 3-Series (E21, E30) 9 06-01-2007 11:02 PM
Very strange sound, need some advice. Vontropnats 3-Series (E36) 8 10-18-2006 01:51 PM
Strange Problem DeathMetal 5-Series (E12,E28, E34, E39, E60) 7 04-20-2005 01:14 PM
Help/advice on strange noise! jclb 3-Series (E36) 16 09-06-2004 01:53 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:26 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.