secondary air system flow - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-08-2008, 03:31 PM   #1 (permalink)
1st Gear Member
 
Join Date: Oct 2007
Car:
Posts: 101
Photos:
whosyadadie01 is on a distinguished road
secondary air system flow

while reading the codes on my 96 328i auto, i got the following codes.

catalyst efficiency below threshold cyl 4-6
secondary air system flow to low cyl 1-3
secondary air system flow to low cyl 4-6

any idea on what could be causing these problems would be very helpful as i dont no where to even begin.
whosyadadie01 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-08-2008, 09:36 PM   #2 (permalink)
3rd Gear Member
 
Join Date: May 2005
Location: Honolulu. HI
Car: E30 318i, E30 318is, E30 M3
Posts: 629
Photos:
dvmotorsports is on a distinguished road
Quote:
Originally Posted by whosyadadie01
while reading the codes on my 96 328i auto, i got the following codes.

catalyst efficiency below threshold cyl 4-6
secondary air system flow to low cyl 1-3
secondary air system flow to low cyl 4-6

any idea on what could be causing these problems would be very helpful as i dont no where to even begin.
with out getting any more info, i'd say faulty cat or O2, and faulty or intermittent secondary air pump operation.
__________________
BMW Technician
dvmotorsports is offline   Reply With Quote
Old 01-08-2008, 10:22 PM   #3 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
could just be the air pump..... maybe causing the cat to error?
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 01-09-2008, 12:03 AM   #4 (permalink)
3rd Gear Member
 
Join Date: May 2005
Location: Honolulu. HI
Car: E30 318i, E30 318is, E30 M3
Posts: 629
Photos:
dvmotorsports is on a distinguished road
Quote:
Originally Posted by AlpineSixAndSeven
could just be the air pump..... maybe causing the cat to error?
probable. depending on when the vehicle throws the code. if he clears it and cold starts the vehicle, and it throws a fault, i would place blame solely on the pump. to the best of my recollection, the secondary air pump it start up operation only. i have been wrong before. but if it throws a pump code and after driving for awhile throws the catalyst code, then it is obviously a different issue.

self explanatory I know. just felt like sharing.

on the other hand, it states this

catalyst efficiency below threshold cyl 4-6
secondary air system flow to low cyl 1-3
secondary air system flow to low cyl 4-6

theoretically it should fault both cats
__________________
BMW Technician
dvmotorsports is offline   Reply With Quote
Old 01-09-2008, 12:23 AM   #5 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
yeah... maybe that cat is on the way out... and the other is in better shape???? Maybe fix the pump issue then clear the codes.... and see if the cat error codes up again......
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 01-09-2008, 12:39 AM   #6 (permalink)
Moderator
 
Dirty_Tool's Avatar
 
Join Date: Apr 2004
Car:
Posts: 1,052
Photos:
Dirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond reputeDirty_Tool has a reputation beyond repute
try tapping on the cat with a rubber mallet and listening to see if it is coming apart on the inside.
__________________
DT




Dirty_Tool is offline   Reply With Quote
Old 01-09-2008, 01:00 AM   #7 (permalink)
3rd Gear Member
 
Join Date: May 2005
Location: Honolulu. HI
Car: E30 318i, E30 318is, E30 M3
Posts: 629
Photos:
dvmotorsports is on a distinguished road
how many miles do you have?
__________________
BMW Technician
dvmotorsports is offline   Reply With Quote
Old 01-09-2008, 01:01 AM   #8 (permalink)
3rd Gear Member
 
Join Date: May 2005
Location: Honolulu. HI
Car: E30 318i, E30 318is, E30 M3
Posts: 629
Photos:
dvmotorsports is on a distinguished road
Quote:
Originally Posted by AlpineSixAndSeven
yeah... maybe that cat is on the way out... and the other is in better shape???? Maybe fix the pump issue then clear the codes.... and see if the cat error codes up again......
exactly. because, the pump can cause a kitty fault but not the other way around. it's possible that the cat fault is erroneous and just there due to the pump failing.
__________________
BMW Technician
dvmotorsports is offline   Reply With Quote
Old 01-09-2008, 01:13 AM   #9 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
^ That is what i thought.... maybe the secondary pump effects cyl 4-6 more?
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 01-09-2008, 01:51 AM   #10 (permalink)
3rd Gear Member
 
Join Date: May 2005
Location: Honolulu. HI
Car: E30 318i, E30 318is, E30 M3
Posts: 629
Photos:
dvmotorsports is on a distinguished road
I'll have to ask at the shop tomorrow.......if i remember
__________________
BMW Technician
dvmotorsports is offline   Reply With Quote
Old 01-09-2008, 02:38 AM   #11 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
^ lol we never do......
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 01-09-2008, 07:40 AM   #12 (permalink)
1st Gear Member
 
Join Date: Oct 2007
Car:
Posts: 101
Photos:
whosyadadie01 is on a distinguished road
thanks guys for all the answers:

the car has 156k miles on the clock

i just replaced both bank 2 o2 sensors with oem from the stealer

ill have to get under my car on a nice day and tap the cat to see if anything rattle's around.


dvmotorsports... if you can ask the shop then that would be great.


ive herd a few things about the secondary air pumps, but never herd of them going bad and even less of when they turn on.


ill have to clear the code's and cold start it later and see if they come back
whosyadadie01 is offline   Reply With Quote
Old 01-09-2008, 04:08 PM   #13 (permalink)
3rd Gear Member
 
Join Date: May 2005
Location: Honolulu. HI
Car: E30 318i, E30 318is, E30 M3
Posts: 629
Photos:
dvmotorsports is on a distinguished road
okay, i spoke with one of my shop master techs today. he happened to have a secondary air pump from an e36 under his tool box. the reason there is no second cat code, is because the second cat is not monitored in that fashion. he said what usually will happen is that the rivets in the plastic cap will break or deform causing little or no air flow due to a leak in the pump. there in lies your problem. the other possibility is that there is a vacuum leak in the hose on the pump. check the hose first. it should be one or the other. change it and you should be good. hopefully its the hose (i'm sure it's a cheaper repair)

good luck
__________________
BMW Technician
dvmotorsports is offline   Reply With Quote
Old 01-09-2008, 05:19 PM   #14 (permalink)
Im Bluffin With My Muffin
 
AlpineSixAndSeven's Avatar
 
Join Date: Nov 2006
Location: Palo Alto, CA
Car: 1976 Benz 300D, 1999 740iL
Posts: 5,992
Photos:
AlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to beholdAlpineSixAndSeven is a splendid one to behold
Send a message via AIM to AlpineSixAndSeven
^ nice hopefully it is just the hose
__________________
1991 Ford Taurs SHO 5 Speed White on Tan
1996 Chevy Lumina LTZ Rep 3.4L
1992 318i Coupe parts car
1992 325i Ls1 swap with a T56 6 speed 12.2 quarter mile
1976 Mercedes Benz 300D with a Ford 5.0L Fuel Injected soon to be Modded
I am Captain Obvious
AlpineSixAndSeven is offline   Reply With Quote
Old 01-09-2008, 10:20 PM   #15 (permalink)
1st Gear Member
 
Join Date: Oct 2007
Car:
Posts: 101
Photos:
whosyadadie01 is on a distinguished road
thanks for the response ... i really wouldnt be surprised if it is a leaking hose, ive been trying to replace the leaking hoses for a while now.

ill start with checking the hose and see where that gets me and let you guys know how it goes
whosyadadie01 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help finding secondary air system pump! jeppcharts 5-Series (E12,E28, E34, E39, E60) 2 02-27-2006 06:06 PM
Secondary Air System Flow Too Low eric 5-Series (E12,E28, E34, E39, E60) 2 03-23-2005 02:23 PM
Secondary Air System Flow nrana99 3-Series (E46, E90) 8 03-22-2005 09:12 AM
secondary air system flow to low 1st Beemer 3-Series (E36) 0 03-25-2004 07:17 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:04 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.