Poor Power Delivery - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-29-2005, 02:09 PM   #1 (permalink)
Neutral Member
 
Join Date: May 2004
Car:
Posts: 92
Photos:
aotiko is an unknown quantity at this point
My car has poor power delivery. Just replaced the spark plugs and I am still having a problem. WHen I floor it the RPMs will go up but the car will not accelerate. THe power will kick in and out until it changes to the next gear and is extremely uneven. What else should I replace? I have a 95 325i auto
aotiko is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-29-2005, 02:55 PM   #2 (permalink)
You Can Has A Custom Title!!
 
thekid's Avatar
 
Join Date: Jan 2004
Location: Jackson MS
Car: 2010 (Prefer not to say here).
Posts: 3,445
Photos:
thekid has a reputation beyond reputethekid has a reputation beyond reputethekid has a reputation beyond reputethekid has a reputation beyond reputethekid has a reputation beyond reputethekid has a reputation beyond reputethekid has a reputation beyond reputethekid has a reputation beyond reputethekid has a reputation beyond reputethekid has a reputation beyond reputethekid has a reputation beyond repute
Send a message via ICQ to thekid Send a message via AIM to thekid
guibo perhaps?... I think I remeber those same symptoms being fixed by replacing it... do a search for Guibo and see if your symptoms match those described in earlier posts.
thekid is offline   Reply With Quote
Old 03-29-2005, 08:15 PM   #3 (permalink)
Neutral Member
 
Join Date: May 2004
Car:
Posts: 92
Photos:
aotiko is an unknown quantity at this point
Quote:
Originally posted by thekid@Mar 29 2005, 02:55 PM
guibo perhaps?... I think I remeber those same symptoms being fixed by replacing it... do a search for Guibo and see if your symptoms match those described in earlier posts.
[snapback]321000[/snapback]
I was thinking it might be the O2 sensor. It only happens when my exaust starts to heat up. If I just turn the car on the power delivery is even. Then once the temperature guage starts to move that's when it happens. I'll replace that and see how it goes.
aotiko is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
European Delivery Update cassidym 5-Series (E12,E28, E34, E39, E60) 8 03-03-2006 08:50 AM
Check Out These E90 Euro Delivery Pics kayoko 3-Series (E46, E90) 12 05-14-2005 09:05 AM
Delivery Tommorow! Questions Moogle M-Series (M1, M3, M5, M6) 10 07-11-2004 01:48 PM
fuel delivery system questions SeatTime 3-Series (E46, E90) 1 10-08-2003 08:29 AM
European delivery bushins Bimmer Talk/Motorsports Talk 4 08-08-2003 10:50 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:25 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.