odometer not working - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-04-2004, 05:58 PM
2nd Gear Member
 
funtoos's Avatar
 
Join Date: Jul 2004
Location: New Jersey
Posts: 365
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
funtoos is an unknown quantity at this point
Send a message via AIM to funtoos
(Thread Starter)
hey guyz,
this is not a bmw question.. but thought i might ask..i m sure somebody must have ran into this situation...
i have a 95 altima and all of sudden the odometer stopped working... everything else works (meaning the rpms, speedometer, all the guages).. but the miles do not seem to move

do you what this can be? where can i start looking?
thanx

'04 330Ci
'00 Kawasaki ZX9-R

Now looking for an M3
funtoos is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-04-2004, 06:02 PM
Been here a while.
 
97alpineM3's Avatar
 
Join Date: May 2004
Location: Virginia
Posts: 5,375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all 97alpineM3 is a name known to all
Send a message via AIM to 97alpineM3 Send a message via MSN to 97alpineM3
Wish mine would do that..... It probably failed due to either a problem with the reels inside.. or with some type of transfer between that and the tires... try looking on the back of your gauges....


1997 E36 M3 1990 E30 325i
97alpineM3 is offline  
#3 (permalink) Old 08-04-2004, 06:07 PM
3rd Gear Member
 
kestrel325is's Avatar
 
Join Date: Jun 2004
Location: Henderson, NV
Posts: 609
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kestrel325is is an unknown quantity at this point
the back of the Altima's gauge cluster (the odometer in particular) is driven by a small motor with a worm gear on it. Over time, the worm gear becomes separated from the driveshaft of the electric motor, and doesn't register the odometer.
Take the gauge cluster out, remove the motor, and push the worm gear back on it. A little dab of superglue will fix the problem.

I had this same thing happen to a friend's 240sx.

There are all kinds of nissan forums available, but the best is
Fresh Alloy

Hope this helps!
kestrel325is is offline  
#4 (permalink) Old 08-04-2004, 08:20 PM
2nd Gear Member
 
funtoos's Avatar
 
Join Date: Jul 2004
Location: New Jersey
Posts: 365
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
funtoos is an unknown quantity at this point
Send a message via AIM to funtoos
(Thread Starter)
kestrel,
does this mean i would have to remove the dash to get to the guage cluster? where is this located exactly... and how hard would this be? u have any dyi on removing the dash to get to it? or am i completely lost?

thanx

'04 330Ci
'00 Kawasaki ZX9-R

Now looking for an M3
funtoos is offline  
#5 (permalink) Old 08-04-2004, 08:51 PM
3rd Gear Member
 
kestrel325is's Avatar
 
Join Date: Jun 2004
Location: Henderson, NV
Posts: 609
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kestrel325is is an unknown quantity at this point
Quote:
Originally posted by funtoos@Aug 4 2004, 08:00 PM
kestrel,
does this mean i would have to remove the dash to get to the guage cluster? where is this located exactly... and how hard would this be? u have any dyi on removing the dash to get to it? or am i completely lost?

thanx
you need to remove the dash surround, as the cluster is held in by 4 screws behind it.

I don't have a walkthrough handy, but try the freshalloy forum. they might have a link that you can use...

All in all, the job's not very hard.
kestrel325is is offline  
#6 (permalink) Old 08-04-2004, 09:04 PM
2nd Gear Member
 
funtoos's Avatar
 
Join Date: Jul 2004
Location: New Jersey
Posts: 365
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
funtoos is an unknown quantity at this point
Send a message via AIM to funtoos
(Thread Starter)
thanx

'04 330Ci
'00 Kawasaki ZX9-R

Now looking for an M3
funtoos is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Spedometer & Odometer Intermittently quit working osestrada 3-Series (E36) 2 10-13-2005 01:17 PM
Odometer Stopped Working jgentile1 3-Series (E21, E30) 2 03-05-2005 03:13 PM
Odometer On Cluster Guage Not Working SemiPerfect 3-Series (E36) 4 10-13-2004 02:28 PM
Odometer Light stopped working kjlbryan 3-Series (E36) 3 05-28-2004 07:12 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome