odometer not lighting up but inspection is - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-31-2004, 07:41 PM   #1 (permalink)
/Banned
 
Join Date: Jun 2004
Location: nap town
Car:
Posts: 251
Photos:
okczy21 is an unknown quantity at this point
i decided to go with the reverse indiglo gauges, everything went great took like an hour to do it, i get everything back together and start drving and my mph gauge isnt working, i take everything back apart then reassemble it and put the cluster back in my car and start driving, now my mph gauge is working but my odometer isnt working (ya know the digital part under mph gauge), when i start my car the inspection crap comes on all lit up

oh yeah on the harness that plugs into the mph gauge i broke the clip but the lever still slides up and down into position, if this matters i dont know, could this be the problem
okczy21 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-01-2004, 07:02 PM   #2 (permalink)
1st Gear Member
 
Join Date: Aug 2004
Location: Stationed in OK :( from DALLAS :)
Car:
Posts: 124
Photos:
dblmikeusa1 is an unknown quantity at this point
I may be going out on a limb here, but I have heard of ESD messing the electronic clusters up. As far as the clip... Are you skilled at electrical repairs? Try to find a junker at a salvage yard and cut the clip off and repair it.
dblmikeusa1 is offline   Reply With Quote
Old 09-01-2004, 07:04 PM   #3 (permalink)
/Banned
 
Join Date: Jun 2004
Location: nap town
Car:
Posts: 251
Photos:
okczy21 is an unknown quantity at this point
just buy a new harness and splice the old wires into the new one?
okczy21 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:24 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.