newbie with weird problem.... - BMW Forum - BimmerWerkz.com
3-Series (E36) Chat relating to the BMW 3-Series from 1992-1999. Autodoodad Specific models include: BMW 316i, BMW 318i, BMW 318iS/ti, BMW 320, BMW 323, BMW 320, BMW 324, BMW 325, BMW 328.

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-02-2010, 07:10 AM
n00b
 
squaddiemarc's Avatar
 
Join Date: May 2010
Location: plymouth
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
squaddiemarc is on a distinguished road
(Thread Starter)
newbie with weird problem....

hi all.just picked up my new beemer a 98 323i coupe.lovely car with only 2 owners from new and full bmw history.
only problem has been smell of fuel from back end after filling up.did some searches on here and ended up checking the fuel pump etc to see if the seal had gone only to find a pipe off!!!

have checked and its meant to be the return pipe but having checked all the pipework from engine back the return pipe goes into the other unit in the tank on the passengers side.no pipes are missing and car runs great with no codes showing.any ideas what to do???have just put a bung on the end at the moment to stop fuel smell. cheers all.
squaddiemarc is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-02-2010, 07:45 AM
n00b
 
Join Date: May 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ReD1007 is on a distinguished road
No pipes should be connected there. I opened mine few days ago (unfortunately not the same model or engine) and there is no hole going into the tank. It just looks like there should be some hose connected. Don't know why.
I also had the fuel smell problem in the cabin. Found out it was the rubber ring. It was bent somehow, and wasn't sealing the tank. Just moved it to the proper position and it's ok now.
ReD1007 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 3-Series (E36)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Problem! g_thebimmer 3-Series (E36) 4 07-23-2008 09:33 AM
WEIRD problem Montizzle 3-Series (E36) 4 06-13-2006 06:43 PM
Weird Problem, Please Help! sunjazz 3-Series (E46, E90) 4 10-25-2004 09:28 AM
Weird problem fushuman 3-Series (E36) 3 09-03-2004 01:20 PM
Weird Question Newbie del23 3-Series (E36) 1 02-26-2004 11:43 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome